netkas.org

Mountain Lion DP2 drops 32-bit kernel support

The kernel and most kexts is 64-bit only now, only few kexts left with 32-bit partm like ati and nvidia framebuffer, ACPIPlatform and appleHDA. full list here – http://pastebin.com/VXtw0BGg

Old mac users (with 64-bit cpus buts 32-bit efi) may try to run ML on their macs using chameleon (forum thread about it) or try to use DP1’s kernel and Extensions folder.

No support for AMD Radeon 7xx0 cads yet

No Kepler nvidia drivers yet, but more things of driver being developing.

Comments

  1. March 18th, 2012 | 12:15 pm

    Oh no…. Apple dropped us…

  2. March 18th, 2012 | 1:38 pm

    […] plus possible de démarrer un Mac doté d’un EFI 32 bits avec Mountain Lion. Apple a en effet supprimé le noyau 32 bits de la DP2. C’est une nouveauté : même si Lion est 64 bits, il démarre quand même en 32 bits sur […]

  3. Squishy Tia
    March 18th, 2012 | 2:35 pm

    While I ain’t happy, I’m not exactly surprised either.

    I’d have less of an issue with this if Apple had a mid-tower Sandy Bridge or Ivy Bridge machine available or in the works, but they don’t and they won’t. They still don’t get the reason that people go hacky is because they don’t need the iMac’s limitations or built in monitor, and the Mac Pros are too expensive.

    Sigh…

  4. March 18th, 2012 | 4:42 pm

    Apple started to screw ourself with this manner. But, i have a hope that this is not true, because In known Issues there is a line “32-bit Kernel Extensions is not supported.” If Apple said that this is a problem, then it will be solved. 32-bit Kexts works only with 32-bit kernel.

  5. jeanlain
    March 18th, 2012 | 7:21 pm

    Yes the lack of support for 32 bit ketx is list in the “know issues”, but I find it dubious.
    To me, it’s clearly not an issue, it’s intentional

  6. Jack Black
    March 18th, 2012 | 7:28 pm

    Hey Nekas,
    I just read the: make your Mac pro a hackintosh guide and yeah it should work since I tried it out in my old Mac Pro a time ago and it runs nice. But Chameleon RC2 does not support Mountain Lion so do we have to use the latest version of Chameleon with the Moutain Lion patch?

  7. tdt
    March 18th, 2012 | 9:34 pm

    I have been dogged by a strange problem with my video card (9600GSO) in which when Desktop appears the fan is at max speed. Another machine with a different NVidia card–GTS250–runs fine at normal fan speed. This did not happen with DP1.
    ANyone has any idea about this? I tried different Chameleon version and FakeSMC, yet it is still the same.

  8. Electropura718
    March 18th, 2012 | 10:38 pm

    Chameleon build R1820 worked with Mountain Lion DP1. Just search for it. Newer and older builds did not work for me.

    I got audio and extra Internal SATA ports working via DSDT.

  9. Bansaku
    March 19th, 2012 | 12:32 am

    @ Jack Black
    Yes, you need to update Chameleon to at least r1820 for ML support. Easiest way is to d/l Chameleon Wizard, and update/install via the a app. 😛

  10. Andreas / mitch germany
    March 19th, 2012 | 1:28 pm

    I found out that Gefore.kext & GeforceGL.kext arent installed by cloning the BASE.DMG (for booting). I am unsure if it was same with DP1, but i cant boot with DP / screen is black after NVHAL registered shown. I use NV 9600 GT.

  11. icanic
    March 21st, 2012 | 9:18 am

    I have read it somewhere that ML Server will work with 32bit and 64bit EFI.

  12. Pinarek
    March 21st, 2012 | 5:56 pm

    I have a problem with my SSD hard drives.

    So I have the iopcifamily.kext the forum here in replacing ML-DP2.
    I had the problem that always (after about 10 minutes running time of the ML-DP2) has one of the 4 SSD drives suddenly orange symbols, in Disk Utility. I thought that it is resolved by replacing the file iopcifamilxy.kext no, this is still the same error.

    In the 4 SSD drives is always another marked with orange symbols.

    And when I come with the ML-DP2 times make a restart, then prior to the 1 or 2 drives not at all recognized by the solid-state drives at boot or will not be there. But if I with the PC-ML DP2 really go down and then turn on again, then all drives (including DVD) weider fully there.

    There seems to be that something in ML-DP2 with the Sata ports not true.

    Someone who has similar problems or symptoms? Someone looking to fix and advice about that?

    Thanks for this info … Translated with Google Translator

  13. Mirone
    March 21st, 2012 | 6:54 pm

    I got up the ML dp1e2 in 64bit made ​​a small change in the bios
    tab: Advanced setup habilitei CPU TM Function and Execute Disable bit.
    Power Managment tab and setup I left ACPI Suspend mode as “Auto” instead of S3.
    thus rose in 64bit.
    I used the chameleon 1860 and the two worked all 1.8 chimera.

  14. NYCWall
    April 11th, 2012 | 9:09 pm

    Maxxuss…

    Dual NVidia Tesla c2070, plus ATI Radeon HD 5700, plus Nvidia H Video cars
    in one 12 core Mac been tested. 8 screens. Also been tested on Intel & Amd
    So far VRAM (6144 mb + 6144 mb +1024 mb + 256 mb)
    Vram Total 12.5 GB.
    ATI Radeon HD 5770:

    Chipset Model: ATI Radeon HD 5770
    Type: GPU
    Bus: PCIe
    Slot: Slot-1
    PCIe Lane Width: x16
    VRAM (Total): 1024 MB
    Vendor: ATI (0x1002)
    Device ID: 0x68b8
    Revision ID: 0x0000
    ROM Revision: 113-C0160C-155
    EFI Driver Version: 01.00.436
    Displays:
    Display:
    Resolution: 1920 x 1200 @ 60 Hz
    Pixel Depth: 32-Bit Color (ARGB8888)
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Rotation: Supported
    NVIDIA Tesla C2070:

    Chipset Model: NVIDIA Tesla C2070
    Type: GPU
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 6144 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x06d1
    Revision ID: 0x00a3
    ROM Revision: preset 1.0.0
    Displays:
    Display:
    Resolution: 1920 x 1200 @ 60 Hz
    Pixel Depth: 32-Bit Color (ARGB8888)
    Mirror: Off
    Online: Yes
    Rotation: Supported

    NVIDIA Tesla C2070:

    Chipset Model: NVIDIA Tesla C2070
    Type: GPU
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 6144 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x06d1
    Revision ID: 0x00a3
    ROM Revision: preset 1.0.0
    Displays:
    SONY TV:
    Resolution: 1920 x 1080 @ 60 Hz
    Pixel Depth: 32-Bit Color (ARGB8888)
    Mirror: Off
    Online: Yes
    Rotation: Supported
    Television: Yes

    Good Luck !!!

Leave a reply