netkas.org

New Radeon 5xxx/6xxx driver In ML DP3

In ML DP3 instead of

ATIRadeonX3000.kext
ATIRadeonX3000GA.plugin
ATIRadeonX3000GLDriver.bundle
ATIRadeonX3000VADriver.bundle

we now has

AMDRadeonAccelerator.kext
AMDRadeonVADriver.bundle
AMDRadeonX3000GLDriver.bundle

which (according to its Info.plist) support radeon 5xxx family and 6xxx family.

But if you look inside of it. it supports more:

AMDR8xxGraphicsAccelerator
AMDBartsGraphicsAccelerator
AMDCaicosGraphicsAccelerator
AMDCaymanGraphicsAccelerator
AMDCedarGraphicsAccelerator
AMDCypressGraphicsAccelerator
AMDJuniperGraphicsAccelerator
AMDLombokGraphicsAccelerator
AMDRedwoodGraphicsAccelerator
AMDTurksGraphicsAccelerator
AMDSIGraphicsAccelerator
AMDPitcairnGraphicsAccelerator
AMDTahitiGraphicsAccelerator
AMDVerdeGraphicsAccelerator

We had signs of this new driver coming in previous versions of ATIRadeonX3000.kext, and now its here !

7xxx series will not work just yet, as it needs FrameBuffer driver first, and this is just accelerator (provides OpenGL&co acceleration)

Comments

  1. CL
    April 19th, 2012 | 9:29 am

    Hope that HD 6770 and HD 6750 will be supported OOB.

  2. Nisse
    April 19th, 2012 | 9:51 am

    Does this make 6950 to work?

  3. GortiZ
    April 19th, 2012 | 1:20 pm

    I hope 6970 will work OOB too :S

  4. April 19th, 2012 | 3:25 pm

    any news about kepler support? would love to replace my gtx 590 with two gtx 680 in the summer :)

  5. alienallan
    April 19th, 2012 | 3:53 pm
  6. alienallan
    April 19th, 2012 | 3:54 pm
  7. DarkSeid
    April 19th, 2012 | 7:37 pm

    Hi,

    Does this mean that using these (or rather updating to ML in due time) could solve my “cannot get 3x 30″ monitors” (2xDVI + 1xDP)” to work on a Sapphire 5770 issue?

    At this point it doesn’t work, and after years i’m actually considering abandoning this scene/the mac.

    Great work as always!

  8. GLibrarian
    April 19th, 2012 | 9:10 pm

    Any info on if any new OpenGL functionality has dropped yet in 10.8?

  9. Nicolas
    April 20th, 2012 | 1:49 am

    Video Glitches GTX470 MLDP3

  10. DeeJay
    April 20th, 2012 | 2:15 am

    DP3 made my NVIDIA 560 card kind of freak out. Forturnately I was able to install DP2 over it and it was OK again.

  11. Bpear
    April 20th, 2012 | 7:16 am

    Anychance of porting these kexts down to lion or snow? To get fully working 6950/70? I currently have it partially working things to your “native package” but things like chess freeze

  12. April 20th, 2012 | 5:01 pm

    [...] netkas, développeur réputé pour ses bidouilles de cartes graphiques pour OS X, a effectivement découvert que la gestion des pilotes de GPU a entièrement été [...]

  13. April 20th, 2012 | 6:01 pm

    [...] netkas, développeur réputé pour ses bidouilles de cartes graphiques pour OS X, a effectivement découvert que la gestion des pilotes de GPU a entièrement été [...]

  14. Nisse
    April 21st, 2012 | 2:21 pm

    Thanks alienallan, back to waiting then i guess.

  15. tdt
    April 21st, 2012 | 6:40 pm

    I looked into /S/L/E of Dp3 but Amdacclerator kext isn’t there. However, it is in the installed partition. How then one would edit the kext prior to installation?

  16. April 22nd, 2012 | 12:45 pm

    Hi, i need some help, let me explain my “troubles”.
    I’ve installed Mountain Lion, Lion to try solve my trouble.
    My system is working well, but i have a micro-lag 0.1 second, mouse pointers stop and works again, i’ve trying the things above.

    1. Repair Permissions
    2. Remove one VGA (HD5870+HD5850)
    3. Disable AppleGraphicsPowerManagement.kext
    4. overclock Pci-E
    5. Overclock CPU
    6. Remove all Sata drives from my PC.
    7. Install Lion/Mountain Lion on SSD
    8. Tried another mouse without luck
    9. Disconnect all my USB devices, didn’t work.

    My System

    Core i7 920
    Asus P6T Deluxe V2
    6GB Patriot Viper 1333mhz
    SSD OCZ 120GB
    1TB Samsung Sata2
    HD5870 XFX + HD5850 Sapphire
    Microsoft Usb 3000 Optical Mouse.

    Thanks, cheers from Brazil.

  17. thowsoon
    April 23rd, 2012 | 12:52 pm

    I want the kext about AMD Radeon HD 6300M

  18. April 25th, 2012 | 8:38 pm

    I’ve managed to fix the “problem”.
    The problem is that i’ve used DVI Input from my monitor i changed to VGA Input, that’s all fixed all my mouse bugs related.

  19. nartes
    April 29th, 2012 | 7:30 pm

    How i can start my ATi Radeon mobility 5650hd with 32-bit kernel (arch=i386) on LION 10.7.3 ?
    It is impossible or not ?

  20. lbfzz
    May 3rd, 2012 | 6:52 am

    ???HD5570 ??1GB DDR3 ??? ID:1002 675F

  21. Predatux
    May 19th, 2012 | 7:00 pm

    Is there any solution for ATI 5730?
    Regards

  22. Predatux
    June 28th, 2012 | 12:13 pm

    @Netkas
    The ATI 5730 card works, but when start the system with PCIRootUID=1, i haven’t graphic acceleration and poor resolution (1152 or 1024).

    If start the system with PCIRootUID=0, i have black screen in my LCD. System works fine, but LCD is always in black. Now, if i connect HDMI output to another monitor or Tv, i have full resolution and perfect graphic acceleration on it while my LDC is in black.

    Have you a solution for it?

    Thanks in advance

  23. random
    June 29th, 2012 | 8:49 am

    Any support for the ATI HD6310 or any HD6300s deviceid=0x98xx?

  24. August 15th, 2012 | 12:04 am

    [...] later Now I have to set up the ATI6970 Will attempt using files from DP4 and replacing out files (http://netkas.org/?p=1084) I guess the graphics should work completely afterwards. Then will set check audio/hard drive [...]

  25. August 16th, 2012 | 12:46 pm

    hello sir first i tested

Leave a reply