netkas.org

Mountain lion GM and Lion new beta

Apple just released ML GM, aka what will be the rtm of ML.

Video drivers in lion was slightly updated.

More info will be posted later.

Interesting things:
1) they have cleaned ML, there is not a single kext with 32-bit part anymore.
2) video driver support is same as in dp4: 6970 with a patch and cold boot bug( cmon apple/amd, you had it fixed in dp2 and have it now fixed in lion). Nvidia gtx670/gtx680 works, no GE/aty_init or efi(on a mac needed)

Comments

  1. hoyanf
    July 10th, 2012 | 10:07 pm

    Excellent… Now just have to wait for release… 😉

  2. nakquada
    July 11th, 2012 | 12:46 am

    Can confirm –

    Mountain Lion GM works flawlessly with my hardware
    Pair of GTX 680s worked out of box.
    All displays (4 for me) outputting, working OOB.

    Easiest install I have ever had to do.

    My system:
    Sabertooth Z77
    Core i7 3770k
    16GB DDR3
    SSD (Windows) SSD (Mountain Lion)
    2 x GTX 680s in SLI

    Hurray!

  3. genzai
    July 11th, 2012 | 4:11 am

    interesting. so in fact when 10.7.5 comes out it will have newer drivers than ML? thats an unusual situation for Apple. But i guess it wont last long. They often release the .1 update pretty quickly after the initial release.
    g\

  4. jafd
    July 11th, 2012 | 5:56 am

    Interesting, did they fix issues which prevented installing on a MacBookPro3,1?

  5. avian
    July 12th, 2012 | 6:37 am

    naquada, which gtx680’s do you have? and does fan speed control seem to be working 100% too?

  6. July 12th, 2012 | 8:23 am

    Mountain Lion GM on a 6950 hang’s at GreyScreen with PowerButton in a Loop, only SafeMode Boot’s. I think the Dropt the Support again scince DP4, but i am not a Pro

  7. JV
    July 12th, 2012 | 10:58 am

    @ nakquada
    Hi, just upgraded my system to IB. I think I’ve made a mistake by choosing 7000 series card. Planning to get a 5870 or 6000 series or gtx 580 (tight budget). Maybe you could email me how you installed OSX on your system? Thanks.

  8. Charly
    July 13th, 2012 | 7:09 pm

    Hi,

    I have a patched ATI HD 4870 (XFX 1 Go) on my Mac Pro (3,1) running 10.6.7. The card works perfectly with 2 displays and QE enabled.

    With Mountain Lion, only 1 display is functional and QE is disabled. I had the same problem with Lion, which is why I’m still using SL. In fact, I couldn’t even update to 10.6.8 because I never found the correct patched driver.

    Is there a fix for the ATI HD 4870 or am I condemned to remain under SL forever?

    Thanks.
    Ch.

  9. nakquada
    July 14th, 2012 | 10:03 pm

    Avian,

    I have two 2GB Gigabyte GTX 680s, they worked out of the box, as did all my Z77 motherboard/ Ivy Bridge CPU. Fan speed and temps are 100% fine. I can try help -> add me on msn: nakquada(at)hotmail(dot)com

    JV,

    I have three systems with 5870s, they all run out of the box aswell, no modification needed. My GTX 580 systems, which I have two of, run out of the box also.

    If it were me I would go for a 580 or 680. Whichever is affordable.

  10. jqlive
    July 23rd, 2012 | 5:32 am

    @nakquada

    Right now I’m running 10.7.3 on a 2x 2.66 GHZ 6-core Intel Xeon Mac Pro with the NVidia patch and a GTX580. It works beautifully without a hitch. I haven’t updated to 10.7.4 because I heard that the Nvidia patch was a bit leaky. So my question, which I think you have answered is:

    Can I run my GTX 580 out of the box with Mountain Lion? or will I need to wait for a new Nvidia patch?

    Thanks for your help.

  11. Ulf
    August 20th, 2012 | 12:34 pm

    And what about Geforce GTX 690 with Mountain Lion? I need a graphic card with a mini display port – I did not find any 670 or 680 with mini display port, only the 690.

  12. Ulf
    August 20th, 2012 | 12:54 pm

    Oh, the GTX 690 is much too expensive … Why can’t nvidia use the mini display port???

  13. Nanzer
    September 9th, 2012 | 7:05 am

    Hey guys
    Noob here.
    Running a Mac Pro 5,1 at stock everything, OS X 10.6.8, upgrading to Lion soon.
    Current card is a 5770, thinking of upgrading to 660, 670 or 680.
    What steps will I have to follow to get it working? I will be using W7 x64 on Bootcamp, but need GPU support on the Mac portion as well.
    Will I need to flash the card? Will an OCed card work as well?

Leave a reply