netkas.org

A small note about using aty_init for nvidia cards in MacPro

As it was discovered, to use PC nvidia card in macpro with injector (e.g. ATY_Init), need to have “helper” nvidia efi card

it’s 7300gt for macpro1,1/2,1 or gt120 for 3,1/4,1 , also it can be 8800gt

helper card need to have not less than 4x pcie lines

Main card can have all 16 pcie lines

such configuration gives MacPro1,1/2,1 the fastest gpu for MacOS ever 😉

Comments

  1. July 20th, 2009 | 4:38 pm

    What is the best gpu for a mac pro 1,1 ?

    ////4870 with efi rom, or injected gtx285/hd4890

  2. Lctrkid
    July 20th, 2009 | 10:09 pm

    I know what is a 4870 with efi rom but… What is an injected card?

  3. zarac
    July 21st, 2009 | 11:00 am

    hey netkas, any chance for qe/ci with 3870 (works only with triakis or megalodon in leo)?

  4. July 21st, 2009 | 8:57 pm

    I have an ati 1900XT in my mac pro. Could i have any problem with the psu if i try an ati 4890 in other pcie ?

    ////read latest entry in blog 😉

  5. UberDuper
    July 23rd, 2009 | 12:10 am

    Tested with ATI 3870 For Mac as the EFI helper and GTX260 in MacPro1,1.
    Not working. Machine hardlocks when switching to graphics/login.

    Removed GTX260 and machine boots on 3870 with injector still installed.

    ////you need nvidia efi helper card

  6. SFMoto
    July 23rd, 2009 | 2:49 am

    Nehalem Mac Pro, 10.5.7, 8800 GTS in slot 1, Apple GT120 in Slot 2. Both are x16.

    No matter what I do, I get a “your computer must be restarted message” if I install ATY_Init.kext. The system works fine without it (well, the 8800 doesn’t work, but no surprise there). I’ve verified owner/group/permissions on the kext. I can kextload from single user mode, but the GUI doesn’t come up after I exit the shell. If there’s anything else I can do to help, let me know – I’m comfortable compiling things, editing plists, etc.

    $ lspci -d 10de:
    05:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
    06:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9500 GT] (rev a1)

    Here’s the output from system.log:

    Jul 22 17:06:47 arthas kernel[0]: ATY_Init: NVIDIA card device-id – 193
    Jul 22 17:06:47 arthas kernel[0]: ATY_Init: nvidia card vram size = 0 b
    Jul 22 17:06:47 arthas kernel[0]: ATY_Init: The 640 card already has keys set

  7. SFMoto-Helper
    August 5th, 2009 | 9:00 am

    hey moto, have you tried installing the drivers for the 8800 on the macpro? the drivers are coming in a pkg file, you must install them or when you use the injector it will not work and crash your system.

    If you have installed drivers, try installing them again, as they are not installed properly for the error messages you are giving the injector does not find the card or its ram, check card connections or that card is not fried

  8. ProMac
    August 6th, 2009 | 1:25 am

    After reading all day long PC200x inject method on this forum (clear and valuable), i tried my self on a fresh install of OSX,

    It work great on a 1st generation mac pro 2006 whith 260 gtx and 7300 helper card

    I’m using injector from this post http://netkas.org/?p=106 and fixed EVGA drivers from this post http://netkas.org/?p=109#comments

    Only 512 of 896 Mo is reconized, it’s no big deal )

    runing leopard 10,5,7, Seven 64 and Ubuntu 64 on 3 display =

    Thanks for all netkas my dream come true !!

  9. Bill
    August 10th, 2009 | 4:35 pm

    Promac, I have a 2006 Mac Pro and am interested in a 260 gtx card. I looked at a GeForce GTX 260 Core 216 which requires a 500 watt power supply. Which card are you using? What are the power limitations in the original Mac Pro?

  10. Bird
    August 30th, 2009 | 3:11 am

    Why does my computer to install nVidia Gtx 285 2GDDR3 in Mac OS X 10.5.8 on the memory to be identified as “VRAM: -2048M” ? I installed the “NVIDIA_Retail_Mac_Driver_Installer_18.5.2f16.mpkg” and “Enabler_for_Nvidia_and_multiple_ATI_cards.pkg”, after which the QE / CI are supported, but is that VRAM is negative, leading to not install Final Cut 3……Who can help me?! Thanks!

  11. May 23rd, 2010 | 2:02 am

    Hi!,

    I’ve a 2008 macpro with 2x3GHz Quad-Core Intel Xeon and a nVidia 8800 GT graphic card.

    I want to upgrade my computer and I have a question about how can I install a pc graphic card in my macpro.

    I think the EVGA “mac version” is expensive and it just have 1GB, but the GeForce GTX285 FTW Edition 2048 MB DDR3 PCI-Express 2.0 is cool. Can it run in macos x 10.6???.

    Please, help me!!

    Thanks and regards

Leave a reply