netkas.org

10.5.8 HD4890 and QE/CI

For 10.5.8 and qe/ci support on 4830 4870×2 3870×2 and 4890 you need patched ATIRadeonX2000.kext

actualy new one doesnt have any important difference, just few strings changed, so you can use the one you used for 10.5.7

But if you care, here is new one patched –  http://is.gd/27Hh3 .

Good luck.

Comments

  1. Lt_Mirage
    August 8th, 2009 | 1:07 pm

    Thank you so much netkas!!!
    I had fiddled with this for such a long time only to find it took just a few seconds and a reboot after installing your new atiradeonx2000.kext patch to make my Powercolor HD4870x2 to have QE and CI on 10.5.8 OSX
    THANKYOU!!!

    Do you have a donate link?

    My Specs:
    Dual Boot: Mac OSX 10.5.8 and Windows7

    Intel e6300 Core 2 duo (1.8ghz @3.7ghz)
    Gigabyte GA-965P-DS3P v2.0
    Corsair 8500 DDR2 1066mhz 2Gb Ram
    2xWD Raptor 74Gb Raid 0 Hard Drives
    1xWD Raptor 150Gb SATA Hard Drives
    Powercolor 1Gb ATI Radeon HD4870x2 QE/CI with netkas ATIRadeonX2000 patch
    Asus DVD Burner SATA
    LG DVD ROM IDE
    Dell 24” 2405FPW LCD Monitor
    SeaSonic 650Watt 80Plus PSU
    Antec P160W Case
    Saitek Eclipse II gaming usb Keyboard
    Logitech MX518 gaming mouse
    Logitech USB Microphone

    /// http://netkas.org/?page_id=20

  2. soloalto
    August 8th, 2009 | 3:56 pm

    Thanks netkas!

  3. chucks
    August 9th, 2009 | 1:09 am

    hey netkas, can you hook up a 4870 driver that suppose dual monitors!!

  4. Wozniak
    August 9th, 2009 | 2:25 am

    Thank You Very Very Much Netkas !!!

    (Mac Pro 1.1 4x3Ghz HD4890 Mac! 1Go)

    Best Regard !

  5. poizonblak
    August 9th, 2009 | 2:45 am

    nothing for 4850??? :(((((

    /////4850 working fine with ATY_init posted few posts ago

  6. Postmaster
    August 10th, 2009 | 1:01 am

    netkad you bad person. Why don’t you make update for nvidia 7600 gs 512 mb RAM pci.
    I try all thing only nvinjectgo. And remembre nvinjectgo is for mobile nvidia. I have
    amd mcp 51 “a8vm-cn 939 i but 7600gs pci.
    Now move you bad ass and make it.
    and remember. Nvinjectgo 512mb RAM is not fully functionaly. Becouse chess.app
    is showing pánic in geforce.kext.
    I Will wait for answer.

  7. Sabi
    August 10th, 2009 | 5:12 am

    lol u cant call netkas bad.. he should banish you from the internet, you should feel lucky u even have internet.

  8. soloalto
    August 10th, 2009 | 1:40 pm

    The patch works great but there is one strange thing. Sometimes when I boot up, QE is disabled on both 4890 and 7300GT. So I should reinstall the patch. Any idea?

  9. poizonblak
    August 11th, 2009 | 5:33 am

    Hi again,
    /////4850 working fine with ATY_init posted few posts ago

    Unfortunately, it doesn’t work for Sapphire HD 4850 512MB Vapor-X which has DVI/HDMI/VGA outputs. I tried every possible ways. When I tried to load the new ATY_init, I got only black screen and my monitor started to switch between Analog/Digital endlessly (It’s connected via DVI output).. Also I got some grey artifacts or black screen that says my monitor doesn’t support that resolution with the previous patches or ways. I am totaly stuck with this kind of 4850. 🙁

    My Specs:

    Dual Boot: Mac OSX 10.5.8 and Windows Vista x64
    Intel e6300 Core 2 duo (1.8ghz @3.7ghz)
    Gigabyte GA-965P-DS4 v1.0
    OCZ DDR2 1066mhz 2Gb Ram
    1xSeagate 500Gb SATA Hard Drive
    1xWD 320Gb SATA Hard Drive
    Sapphire HD 4850 512MB Vapor-XATIRadeonX2000 patch
    Samsung DVD Burner SATA
    Samsung 21.5″ P2250 LCD Monitor

  10. libbi
    August 15th, 2009 | 5:20 am

    I have low profile radeon hd4350/4550 512mb in my dell optiplex 755, where to find drivers?

    ////nowhere

  11. Radiance
    August 15th, 2009 | 5:35 pm

    Thanks for all the great work!

    I’ve got my Sapphire HD4830 (DVI/HDMI/VGA) with QE/CI. I’m running on 10.5.8 and using the 64bit mod motmotfb natit.

    The problem is that there is no signal on the HDMI port (after starting the loginwindow it shows the blue background and then the signal is gone), I’m now using VGA but it lacks support for widescreen resolutions.
    My monitor is connected via a HDMI cable on the HDMI port, but this isn’t working. I would like to use the hdmi port, is there a solution to this problem (next to buying a dvi cable or dvi->hdmi)?

    ///use dvi2hdmi

  12. vlad1966
    August 16th, 2009 | 10:26 pm

    What about sleep?
    I can sleep my XFX 4890, but when it wakes my Hack I get gabled graphics.

  13. vlad1966
    August 16th, 2009 | 10:27 pm

    What about sleep?
    I can sleep my XFX 4890, but when it wakes my Hack I get garfeesbled graphics.

  14. mitien
    August 17th, 2009 | 9:37 am

    tnx, but link is broken:(

    ////its not broken, you need some brain to get files 😛

  15. mitien
    August 17th, 2009 | 7:53 pm

    it leads on http://pastebin.com/me41a6f2
    sorry but i have brain and no link to download))

  16. mitien
    August 17th, 2009 | 7:56 pm

    found it)

  17. lernyhard
    August 20th, 2009 | 11:58 pm

    Does it work for HD 4870 4890 with 2GB? thank you

    ///2gb ram card has problems with opengl, amount of reportef vram there is -2gb, not 2gb

  18. September 8th, 2009 | 7:18 am

    Hi…
    I have a problem. When I boot up, QE is disabled on both 4890 and 7300GT. Should I consider reinstalling the patch?

  19. jonnyhackymac
    September 9th, 2009 | 8:48 am

    I would love a copy of the patched
    ATIRadeonX2000.kext but link leads to Unknown post id, it may have expired or been deleted. Can u repost a new link please.

  20. acetone
    September 10th, 2009 | 5:09 pm

    Sorry, English is not my natural language….

    Link seems to be broken ?

  21. ron2
    September 24th, 2009 | 3:59 am

    Netkas, can you reupload this file? The link you provided seems down ;-(

    Thanks again for your help.

    ////google: qe_ci_exotic 10.5.8

  22. dotzev
    September 25th, 2009 | 4:47 pm

    Hi,I’m new…I’d like to ask witch driver is the right one for me?I need a driver that will allow my MSI 3870×2 to use
    3D acceleration so I can play some games…
    I’m using iPC Final.

  23. skypete
    September 26th, 2009 | 12:46 am

    hey netkas can u please repost the link it is not working thank again.

  24. November 28th, 2009 | 4:55 am

    Спасеба за ету очен харошеу програмау!

  25. rxbeat
    January 12th, 2010 | 1:24 pm

    hey… hi all
    i need help !
    have a 3870×2
    a GeCube xhd3870x2 with 4xDVI
    i need only 2 DVI’s !

    in my extensions, this driver are installed

    ATINDR.kext
    ATIRadeonX2000.kext
    ATY_Init.kext
    ATY_Triakis.kext

    now i can run 4 Monitors !!!
    NO QE and NO CI
    When i install some other drivers
    than i have QE on the first monitor !
    all other monitors work without QE.
    Problem is, i can’t start applications.
    Without QE and CI i can start some applications.
    What i can do?
    Need Driver for xhd3870x2
    sorry for my bad english
    greetz from germany

  26. rxbeat
    January 12th, 2010 | 1:25 pm

    ahhhh
    for —> 10.5.8 <—

  27. gkhnx
    January 16th, 2010 | 1:52 pm

    any ideas for ati radeon x1550?

  28. March 14th, 2010 | 3:53 pm

    Hi!

    Em new to this blog! Why all links are redirecting to rapidshare…..?

    No link starts downloading…….

    Thank You

  29. March 15th, 2010 | 8:23 pm

    Can you please update the download link.

    Thank You.

  30. LoLL
    March 16th, 2010 | 12:22 am

    Hi,
    Look for the file on google and forums but i vain. Any chance to have an updated link for QE_CI_Exotic_10.5.8.pkg ?
    Thanks for your time.

  31. mordi
    April 13th, 2010 | 12:00 am

    pls i need this file, pls reupload it !

    THX

  32. mauha
    April 21st, 2010 | 6:23 pm

    Hi! I have 10.5.8 and a Hd4890 i installed ATY_init.kext and the “QE_CI_Exotic_cards.pkg”, but this doesen´t work. So i want to try this, but it´s offline can you reupload please?

  33. Kexit
    April 28th, 2010 | 1:41 am

    When it finally be the solution for the HD3470

  34. Mirrors
    May 3rd, 2010 | 11:25 pm

    For anyone still looking for the pkg. I’ve finally found it.

    http://x86osx.com/bbs/view.php?id=news&page=2&sn1=&divpage=1&sn=off&ss=on&sc=on&select_arrange=headnum&desc=asc&no=1748

    The site’s in Chinese, but the button to the right of “QE_CI_Exotic_cards_10_5_8.pkg (755.2 KB)” starts the download.

  35. WiZE
    May 14th, 2010 | 1:27 pm

    could you please upload the file to megaupload or speedyshare, because it seems that rapidshare is broken

  36. kc moore
    November 22nd, 2010 | 4:07 am

    this is the actual download link from the button posted by mirrors thx

    http://x86osx.com/bbs/download.php?id=news&no=1748&filenum=2

    the link works click the button next to ?QE_CI_Exotic_cards_10_5_8.pkg (755.2 KB)?

    in the first post

  37. Miya
    May 16th, 2011 | 8:25 pm

Leave a reply