netkas.org

fix for Acer laptops

Some acer laptops (5920 for example) freezes sometimes durring osx boot, before root partition mounted.

It seems to be caused by AppleUSBUHCI.kext

and here is how to fix it:

1) open this file /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBUHCI.kext/Contents/Info.plist (you need root rights to edit this file)

2) find this text there :

<key>OSBundleRequired</key>
<string>Root</string>

and replace it with

<key>OSBundleRequired</key>
<string>Safe Boot</string>

3) run this command to update caches

sudo touch /System/Library/Extensions/IOUSBFamily.kext /System/Library/Extensions

4) done

Comments

  1. Oatman
    August 31st, 2009 | 10:04 pm

    Thank you so much I appreciate your work like crazy but can we please get the Intel ATA Kext’s fixed….

    I can’t even get past boot because w/out the kext it shows my cpu panicing. With the kext it says stuff about ahchi.kext or something like that. I am not big on hardware im a software person but we really need to get some kind of achi and ata injector to let the OS even boot.

  2. Oatman
    August 31st, 2009 | 10:06 pm
  3. rennerst
    August 31st, 2009 | 11:08 pm

    Hi Netkas,

    thank you, this functioned also for my HP 530 laptop.

    Greetings

  4. youminbuluo
    September 1st, 2009 | 12:27 am

    my lenovo laptop freezes too
    hope this fixes

  5. VooD
    September 1st, 2009 | 1:25 am

    Using the USB fix option from Chameleon2 also seems to solve the problem.

  6. Nemes
    September 1st, 2009 | 6:51 am

    This is a bit off-topic, but speaking of screwy things occurring under Snow Leopard…

    On Asus’s X58-based boards (P6T, Rampage II Extreme), there’s something wrong with AHCI under SL. When AHCI mode is enabled, any drives other than the boot drive get ridiculously poor performance; fractions of a MB a second. The boot drive itself is fine, and if you do something to load down the boot drive (such as running the XBench drive test), the performance on the other AHCI ports picks up to normal levels.

    Other than switching to IDE mode, no one has been able to identify the cause of the problem. I know you don’t have any of the affected boards, but would you happen to have any insight on to what may be causing the issue, Netkas?

    For more details: http://www.insanelymac.com/forum/index.php?showtopic=181981&st=0

    And thank you ahead of time.

  7. d3d
    September 1st, 2009 | 7:48 am

    It’s not only acer laptops problem. Sometimes my intel x58 mobo freezes. Thank’s for solution!

  8. September 1st, 2009 | 7:55 am

    […] problem fix (for laptops) Netkas wrote an article on his blog about this. So if so do check it out here . Netkas wrote a guide on how to fix it. Again we we’ll have to wait till Slice comes up with […]

  9. oldnapalm
    September 1st, 2009 | 4:03 pm

    UHCIreset=Yes also solves the problem for me.

  10. razvizion
    September 3rd, 2009 | 2:57 am

    http://www.mediafire.com/download.php?llmtngbowoh This file also solves camera issue in acer 5930 tell me, if someone else has problems with internal video cam try this file, under -x32 -x use kext ultility to install 😉 than reboot and boot normally

  11. April 21st, 2010 | 9:55 am

    […] it the usb? check this here __________________ either way,the is the […]

  12. August 12th, 2011 | 7:47 pm

    […] remember this? […]

Leave a reply