netkas.org

Collecting some data from macs, for pc_efi.

I found out that we can get rid of natit in some situotions.

to make this i need some info from real macs

to get this info make next commans

ioreg -l -w0 -p IODeviceTree | grep device-properties > dump.txt

compress dump.txt , upload it and post link to file in comments.

That would help  a lot.

Thank u guys for dumps. I just made my 2600XT works without natit, with 10.5.1 atindrv ! 😀

All keys set by pc_Efi, woot.

Also we got GeForce 8800 GTS /GTX to work this way!

P.S. we already have this dumps from MBP with gf8600 (15″ and 17″) and from MacBook. do not post dumps from this systems.

Comments

  1. no.xqs
    November 24th, 2007 | 9:05 pm

    http://rapidshare.com/files/72020958/dump.zip.html

    Latest Imac 24″ 2.4Ghz, 2GB Memory

  2. no.xqs
    November 24th, 2007 | 11:29 pm

    I also ran this command:
    ioreg -l -w0 -p IODeviceTree > DT_iMac_HD2600Pro.txt

    Hope its helpfull

    http://rapidshare.com/files/72048585/DT_iMac_HD2600Pro.zip.html

  3. November 24th, 2007 | 11:46 pm

    MacBook Pro 17″ Core Duo (1st Gen) 2GB RAM with ATI Radeon x1600 Pro

    http://rapidshare.com/files/72051074/dump.txt.zip.html

  4. netkas
    November 24th, 2007 | 11:51 pm

    Thank you, i made my 2600XT work WITHOUT natit!

  5. collit99
    November 24th, 2007 | 11:56 pm

    will this project work on GMA950?

  6. dax
    November 25th, 2007 | 12:13 am

    http://www.mediafire.com/?2299n4m3mzp

    MBP 1,1 1.83ghz
    ATI x1600 128mb

  7. XyZ
    November 25th, 2007 | 12:26 am

    [quote]I just made my 2600XT works without natit, with 10.5.1 atindrv ![/quote]
    Well It works for me to on 2600XT!
    Still one monitor(dvi2vga), but this can be fixed right?
    Thanks!

  8. netkas
    November 25th, 2007 | 12:41 am

    collut99

    we can try already gma950 on laptops, but for desktops we need macminis dumps

  9. November 25th, 2007 | 12:58 am
  10. netkas
    November 25th, 2007 | 2:15 am

    tried macmini’s dump to get gma950 working – no luck

    guess it uses some osrt of internal conencters in macmini

    and we confirmed G80 cards work

  11. zascok
    November 25th, 2007 | 7:55 am

    netkas, could you tell more about gf8600?
    thx

  12. jharleman
    November 25th, 2007 | 8:23 am

    Rock star, superb, maybe throw in Intel HDA to boot? Any chance of adding different models to the mix such as MBP’s for us santa rosa laptop people? cheers – jl

  13. cooler2900
    November 25th, 2007 | 9:33 am

    Awesome work. Pls also look at Paulicats GMA Natit http://tinyurl.com/2yt7ka perhaps you can make it work!

  14. Naeem
    November 25th, 2007 | 11:30 am

    Hi, netkas, will my Geforce 8400 GS work and if yes where can i find the more information. Thanks and regards.

  15. netkas
    November 25th, 2007 | 12:36 pm

    I dunno, will 8600 work or not, need smbd to test it

  16. lastExile
    November 25th, 2007 | 1:08 pm

    Great !! 🙂

  17. fabcat
    November 25th, 2007 | 2:19 pm

    This looks very promising and is excellent news. Does this also mean that we might not need to add our vendorid/productid etc to various drivers? If that is the case, then that will help make software updates easier. Even if it is not the case it is still good.

    Will this EFI info relating to hardware need to be compiled into the secondary bootloader, or will the boot loader be able to read from a file just the EFI details needed for each users specific hardware?

    Just curious. In any case it is all very good news.

  18. Berekef
    November 25th, 2007 | 2:43 pm

    can this help 8800GT???
    Is there any way i can help with something?

  19. macmac
    November 25th, 2007 | 2:52 pm

    does it already work with ATI X1600 or Geforce 7600GT ?

  20. Zhta
    November 25th, 2007 | 3:01 pm

    Great news Netkas !! Is there any hope for the NVidia Go series for the laptops (internal monitor not working) ?
    Thank you for your work,
    Dimitris , Greece

  21. zascok
    November 25th, 2007 | 3:14 pm

    netkas , I have GeForce 8600GT 512MB DDR2 PCI-Express and I do not mind to test it.
    thx

  22. Pinturikkio
    November 25th, 2007 | 3:17 pm

    can i test it for u?….i’ve got 8600m gt….i can try all u want ;).. Now with nvinject 0.1.5 my card is recognized but system freez…i’ve got efi 5.2 and leo 10.5.1….

    my email: super_saynman@hotmail.com
    i’m waiting for u 🙂

  23. Pinturikkio
    November 25th, 2007 | 3:18 pm

    ops sorry….

    email: super_sayanman@hotmail.com

    😉

  24. slakkur
    November 26th, 2007 | 2:17 am

    http://rapidshare.com/files/72303673/MacPro2.66x1900dump.txt.zip.html

    Model Identifier: MacPro1,1

    ATI Radeon X1900 XT:

    Chipset Model: ATY,RadeonX1900
    VRAM (Total): 512 MB
    Vendor: ATI (0x1002)
    Device ID: 0x7249
    Revision ID: 0x0000
    ROM Revision: 113-A52027-140
    EFI Driver Version: 01.00.140

  25. TorqueX86
    November 26th, 2007 | 4:23 am

    Thanks to Slakkur for the X1900 Mac Pro dump!

    http://rapidshare.com/files/72303673/MacPro2.66×1900dump.txt.zip.html

    Incoming love for x19×0 users!

  26. Goron
    November 26th, 2007 | 8:15 am

    netkas:

    thx a lot for your work!!! Working 10.5.1 via Software update with efi_v52 🙂

    Do not own a card like that, just onboard GMA950 and a x1950GT 512MB which will be shipped tomorrow …. i´ll report on that ..

  27. SEEYOU
    November 26th, 2007 | 11:55 am

    Mac Pro 2x 2.66GHz Dual-Core Intel Xeon, Nvidia 7300 GT

    http://rapidshare.com/files/72370744/dump.txt.zip.html

  28. KreizO
    November 26th, 2007 | 3:34 pm
  29. slakkur
    November 26th, 2007 | 4:34 pm
  30. raggedjagged
    November 26th, 2007 | 6:17 pm

    So any chance for te 8600M-GS or the 8400M-GS to get working? I’m really wondering because I’m going to buy a new laptop soon with either of those cards and I want to know is osx would run on it with good support for those video cards.

    Please let me know someone, Thanks! 🙂

  31. mihai
    November 26th, 2007 | 9:47 pm

    MacBook Pro 2,2 15″ C2D 2.16GHz

    http://www.mediafire.com/?e272zpeuu5j

  32. mvm212
    November 28th, 2007 | 6:44 am

    Did not get any info from your suggested grep, so here is the whole IOReg dump: Video card info is around line 1394 to 1492. Its for a GeForce 6600GT.

  33. mvm212
    November 28th, 2007 | 6:48 am

    Sorry, forgot to include the paste:

    http://www.pastebin.ca/800186

  34. Pinturikkion
    November 30th, 2007 | 3:01 am

    I tried with EFI 6.0 and boot_gf8600 but noothing!!! 🙁

    My 8600M GT doesn’t want to work!!

    I tried also with NVinject 0.1.5 Leo and boot_gf8600…Nothing too!!

    Netkas help us!!

    I’m here like a tester for u…u’ll find my msn on my last post…

  35. sanXp
    November 30th, 2007 | 8:25 am

    iMac6,1 24″ 2.16GHz, 7600GT

    http://www.mediafire.com/?7ufxxyp2202

  36. theslug
    December 1st, 2007 | 9:02 pm
  37. jjduro
    December 7th, 2007 | 8:56 pm

    Here is the dump for nVidia Geforce 7300 Go

    http://www.pastebin.ca/808651

  38. ibob
    December 10th, 2007 | 5:21 am

    Maybe someone can find a GF 8600 GT and plug on a MacPro and get the dump ???

  39. ibob
    December 10th, 2007 | 2:20 pm

    Slakkur or SEEYOU, can you guys do a big favor to the creew ? 🙂
    Find some friends with PCI Ex cards, the most complicated to find, but used by osx, like the GF 8600 GT, 7900 GT, and plug it on the MacPro and get the string?

    Can be a goood contribution!!! THANKS!!!

Leave a reply