netkas.org

Ohai Atheros

Image Hosted by ImageShack.us

Latest 10.6.2 beta has kext named AirportAtheros21.kext, just add there your dev-id, test and check if it works, devid = 0013 works.

Also its possible to use old kext for 32-bit and new for 64-bit automaticaly.

Comments

  1. it'sme
    October 22nd, 2009 | 11:54 am

    is this a generic atheros kext?
    can’t wait for the details!

  2. youminbuluo
    October 22nd, 2009 | 1:12 pm

    I have just bought a bcm4321 card 🙁

  3. nerone
    October 22nd, 2009 | 3:31 pm

    great! can’t wait for the details.

  4. loll
    October 22nd, 2009 | 4:17 pm

    No intel 5100 ? ;-]
    pfff hard life for centrino* notebook users

  5. yoyodude
    October 22nd, 2009 | 7:22 pm

    Interesting, I guess there’s no Apple product out yet that actually uses the Atheros chips?

  6. claude
    October 22nd, 2009 | 7:24 pm

    Hi thanks for the info

    I’ve the AR9285 found for ex. in eeepc 1005HA, but still not recognized in 10.6.1. Do you know if 10.6.2 update will make it work ?? Where can I download this kext to try it ? I see no links

  7. claude
    October 22nd, 2009 | 7:46 pm

    I forgot to add that my device is 168c:002b

  8. Cart
    October 22nd, 2009 | 7:48 pm

    AR5005?? AR5007??? Any reports?!?!

  9. JSmiley
    October 23rd, 2009 | 4:40 am

    With Demonoid down for the time being its very hard to find that 10.6.2 seed 🙁

  10. nour
    October 23rd, 2009 | 7:14 am

    Thnaks a lot,
    Can you post a link to this kext ?

  11. tea
    October 23rd, 2009 | 7:21 am

    May be some one can share this kext from latest 10.6.2 build?

  12. October 23rd, 2009 | 8:20 am

    Неткас, выложи кекст куда-нибудь, будь другом.

  13. October 23rd, 2009 | 3:59 pm

    I would like to try, but as said before, never seen the 10.6.2 for download over the web.

    If someone can share it with us…

  14. leveex
    October 23rd, 2009 | 5:56 pm

    Does it work WPA?

  15. Klaas Kramer
    October 24th, 2009 | 4:28 pm

    If AR5007EG works, I will cry of happiness 😀

  16. slipttees
    October 26th, 2009 | 2:34 am

    yoo…..no more 32bit, great news jedi netkas ! ^^

  17. koeritza
    October 26th, 2009 | 12:09 pm

    Working in 64bit for my AR5008 (DWA-556) after adding device-id. But sleep is broken, it reboots when waking up.
    Not that sleep is usefull when using the wireless on a hackintosh, the device becomes not working after a wake up anyway.

    ///for me, reboot on wake-up caused by AppleLPC.kext

  18. claude
    October 26th, 2009 | 6:54 pm

    tried it on 168c:002b (AR9285) = fail no network found

    console says :
    Airport : link down on en0. Reason 1 (unspecified)
    airportd MIG failed (PowerEnable Event) = 5 (Input/output error) (port = 44819)

    diagnostics messages:

    airportd[55] [most time: (1.100088) _scan] trace: {type = mutable-small, count = 14, values = (
    0 : {contents = “pref_netwk_AJ”}
    1 : {contents = “1_pref_netwk”}
    2 : {contents = “(1.085532) _scan”}
    3 : {contents = “(0.000002) _lookup”}
    4 : {contents = “(0.298647) _scan”}
    5 : {contents = “(0.000002) _lookup”}
    6 : {contents = “(1.076359) _scan”}
    7 : {contents = “(0.000003) _lookup”}
    8 : {contents = “(0.000001) _lookup”}
    9 : {contents = “(1.079282) _scan”}
    10 : {contents = “(0.000002) _lookup”}
    11 : {contents = “(0.000001) _lookup”}
    12 : {contents = “(1.100088) _scan”}
    13 : {contents = “fallback”}
    )}
    com.apple.message.domain: com.apple.airport.autojoin.summary
    com.apple.message.signature: NoNetworksFound
    com.apple.message.result: noop
    com.apple.message.value: 4.666440
    com.apple.message.value2: 1.000000
    com.apple.message.uuid: C7D1034A-41A8-46C7-A485-322DF8DC1A6D

  19. scoobydu
    October 27th, 2009 | 11:28 am

    *koeritza

    Are you just placing the atheros kext in /Extra or leaving the kext inside IO80211Family.kext? and putting in /Extra?

    Presume you are using deviceid 0024

    Thanks
    scooby

  20. scoobydu
    October 27th, 2009 | 2:34 pm

    Ok /Extra doesn’t work for me. Modifying the original kext does.

    24 works, 0024 doesn’t.

  21. October 28th, 2009 | 9:44 pm

    ok guys, CAN SOMEONE SHARE IT please?

  22. XPbIM3
    October 30th, 2009 | 3:05 pm

    devid 1c. still not working(
    🙁

  23. bio
    November 3rd, 2009 | 10:55 am

    wow, great news!

  24. Patrik
    November 12th, 2009 | 1:40 pm

    slightly off-topic question: from what utility/program is that screenshot taken?

  25. AR9285
    November 13th, 2009 | 2:09 pm

    not working on 10.6.0 with 168C.002B Atheros AR9285
    Airport menu, but no network found.

  26. November 13th, 2009 | 11:59 pm

    How may I add an ID to the Info.plist? Where may I look for my card ID?

  27. November 18th, 2009 | 7:52 am

    I have also bought an dell1490, but havent installed it yet lol
    I hope this kext supports my Atheros WiFi.

  28. November 21st, 2009 | 3:36 pm

    Basically the AR9285 is ONLY recognized.. (No Networks)
    I am working on a Toshiba NB200 and I tried to turn off the wireless from the BIOS and Mac OS still recognizes it as “ON BUT NOT WORKING”…

    Any help/patch from anyone?

  29. ULTIMATI
    December 18th, 2009 | 2:20 am

    p168c,2a

    console says :
    Airport : link down on en0. Reason 1 (unspecified)
    airportd MIG failed (PowerEnable Event) = 5 (Input/output error) (port = 44819)

    diagnostics messages:

    airportd[55] [most time: (1.100088) _scan] trace: {type = mutable-small, count = 14, values = (
    0 : {contents = “pref_netwk_AJ”}
    1 : {contents = “1_pref_netwk”}
    2 : {contents = “(1.085532) _scan”}
    3 : {contents = “(0.000002) _lookup”}
    4 : {contents = “(0.298647) _scan”}
    5 : {contents = “(0.000002) _lookup”}
    6 : {contents = “(1.076359) _scan”}
    7 : {contents = “(0.000003) _lookup”}
    8 : {contents = “(0.000001) _lookup”}
    9 : {contents = “(1.079282) _scan”}
    10 : {contents = “(0.000002) _lookup”}
    11 : {contents = “(0.000001) _lookup”}
    12 : {contents = “(1.100088) _scan”}
    13 : {contents = “fallback”}
    )}
    com.apple.message.domain: com.apple.airport.autojoin.summary
    com.apple.message.signature: NoNetworksFound
    com.apple.message.result: noop
    com.apple.message.value: 4.666440
    com.apple.message.value2: 1.000000
    com.apple.message.uuid: C7D1034A-41A8-46C7-A485-322DF8DC1A6D

  30. ULTIMATI
    December 18th, 2009 | 2:21 am

    need pacth does anyone have the patch yet

  31. sunnyp
    December 28th, 2009 | 3:22 am

    Have an Asus 1005ha – AR9825 – SN 10.6.2 with AR kext. Card is recognized, but can’t scan or connect.

    Any update??

  32. Alexlexus82
    January 23rd, 2010 | 10:06 am

    Asus ul20a, only recognized, No Networks
    Any update?

  33. March 4th, 2010 | 5:43 pm

    Hey guys – it´s very hard to find the right torrXXX on any page! is it possible, that you can give me a hint how the file is named!?

    Thank you very much!!!

  34. Sarge
    March 15th, 2010 | 9:32 pm

    AR9285

    Please, we’re a lot of people waiting for a working driver…
    Thanks in advance.

  35. Knightpm
    May 27th, 2010 | 6:50 pm

    Any word yet on a working driver

    Thanks

  36. reeve24
    June 29th, 2010 | 7:24 am

    any news about Atheros AR9285? 168c,002b? We’re still looking for it.. please someone?

  37. MrZeroo00
    August 22nd, 2010 | 3:21 pm

    No news for Atheros AR9285 168c,002b we need it :(.

  38. September 11th, 2010 | 5:24 pm

    Good news : Atheros AR9285 168c,002b is working under MacOSX 10.6.3 and 10.6.4 from official release installed on Asus 1005HA.
    Just install IO80211Family.kext version 3.1.2 that weights approx 11,9 Mbytes and insert your Device ID if not already inside info.plist (in the AirportAtheros21.kext).

    IT IS WORKIN ON 1005HA with stock wlan card, but only for opened and wep networks. I can get internet connection.

    wpa network doesnt seem to respond even if connected to it.

  39. fgi
    December 8th, 2010 | 5:42 pm

    where link to downloaD?????

Leave a reply