netkas.org

Intel HD Graphics and OSX

Apple posted update for new MBPs

Inside we have two new kexts (and some bundles for it), and these kexts have device ids of supported devices

AppleIntelHDGraphicsFB.kext – 0x00468086 0x00428086 (It is the framebuffer)

AppleIntelHDGraphics.kext – 0x00448086 0x00468086 (it is the accelerator)

These devids is for

0042 Core Processor Integrated Graphics Controller (clarkdale’s (desktop) core i3/i5 gpu)
0044 Core Processor DRAM Controller
1025 0347 Aspire 7740G
0046 Core Processor Integrated Graphics Controller (it’s probably arrandale’s (mobile) core i5/i7 gpu)

Good luck in trying these kexts!

Comments

  1. rentao
    December 4th, 2010 | 8:20 am

    check out the Reference Guide for the Intel HD Graphics from the official website:

  2. AjGilee
    December 5th, 2010 | 9:25 pm

    Could some please make a patch of these Intel HD kext to work please.. especially for GMA 4500 series. It looks pretty similar with the HD.
    http://software.intel.com/en/articles/quick-reference-guide-to-intel-integrated-graphics/

    Please…

    Netkas?

  3. Nicolas
    January 2nd, 2011 | 1:57 am

    Hi,

    I got an intel hd graphics integrated in my laptop Toshiba L635 (cf below). Seems pretty difficult to get it working good!
    I’ve tested it with the new kernel darwin 10.5.0 (which contain some kext for intel graphics, but it’s not booting with it…). I have to erase all the “intel hd” kexts to get X working!

    Anyone get the solution to get this video card working with kext?!?

    Thx
    —————————————-
    intel core i5 450m 2,4ghz
    intel hd graphics (ven:8086 dev:0046)
    iatkos s3 v2 + combo update + multibeast
    —————————————-

  4. dave
    January 25th, 2011 | 4:05 pm

    guys, i tried several things but i just can’t make any improvements.
    i got a asus k52jc laptop with an i3-350m, intel hd graphics & nvidia 310m. i injected the device-ids or tried several enablers – none worked for me.
    as i created a efi string and imported it to the com.apple.boot.plist, i got a kernel panic. i think it came because i tried to choose se internal monitor as the output.
    so my next question would be if there is any possibility of either turning the hd graphics off (i found none except gfxstatus but it requires full kext-loaded graphics as i do not have) or is it probably possible to change the output of the hd graphics?
    not even the d graphics has a ket loaded …

  5. laocai
    January 29th, 2011 | 11:36 am

    lenovo K26
    Intel HD Graphics (Ironlake) (8086-0046)
    [Video chipset]
    Video Chipset: Intel HD Graphics (Ironlake)
    Video Memory: 1024 MBytes

    [Video Card]
    Video Card: Intel Auburndale/Arrandale Processor – Integrated Graphics Controller [Lenovo]
    Video Bus: PCI
    Video RAMDAC: Internal
    Video BIOS Version: 1976 PC 14.34 01/15/2010 03:51:43

    [Performance]
    Processor Clock: 366.7 MHz

    It can install Mac OS X 10.6.4
    use your driver under bootthink
    it’s not work
    only 1024X768

    please help me ,thanx

    zhejiong@126.com

  6. Glenox
    February 25th, 2011 | 3:00 pm

    Hello,
    New MacBookPro 13′ comes with an Intel HD Graphics 3000 solo card.
    Hope mod kexts will be aviable soon to run with QE/CI on our OSX86 machines.
    Hope you will help us this way Netkas.

    Thx
    ———————————————-
    PowerHack G5 – Snow/Ubuntu/Win7
    (GA-G31M-ES2L/E7600@3GHz/4Gb/1,75Tb/9400GT)
    eMac G4 – Leopard
    (1,42GHz/1Gb/160Gb)
    PowerHack G4 Quicksilver – Snow/Ubuntu
    (GA-G31M-ES2L/E5200@2,8GHz/4Gb/160Gb/9400GT)
    PowerHack G4 AGP – Snow Server
    (Asus A8N-SLI/X2@2,8GHz/2Gb/160Gb/8600GT)
    iPhone4 16Gb -iOS
    HP G62 140EF – Win7 :(
    iMac G3 Tangerine – Panther
    (260MHz/256Mo/20Gb)
    ———————————————-

  7. shelvon
    March 17th, 2011 | 1:58 pm

    Hello,
    It sounds like a good news!
    Since New MacBookPro comes with an intel HD Graphics 3000 solo card, why there isn’t any patch for x4500hd until now.
    Are HD3000 and x4500hd quite different, or we have to wait for the patch?
    Is there any hope for running with QE/CI on Leopard?
    thx

  8. fengty
    April 1st, 2011 | 4:51 am

    help gma 4500 for qe/ci

  9. Ro
    April 8th, 2011 | 6:52 pm

    This kexts will work witch asus u30jc? They has core i-3 witch intel HD graphic and nvidia m310?

  10. mkgiver
    May 23rd, 2011 | 1:59 pm

    Hi Netkas, I have an idea, would be posible to inject via chameleon the gma3100 ROM so the proper kexts loads ???

    the rom needs to properly patched to get it working. So could be the begining.

    thanks in advance. And Remember “YES WE CAN”.

  11. decard
    May 24th, 2011 | 9:15 pm

    Hi guys ive been using osx86 since day one … about 7 yrs now …….. no problemos
    one thing that you guys have is that QE is mainly for apple software ///like FCP …logic and so on
    otherwise everything works better than a real mac the only thing to do is on the resolution side…..but if you are mainly a net user it is just perfect I am a Graphic designer and I use CS5 on a dell running 10.6.3 no QE need it do not have lots of money but i do have lots of mac machines and Hacks too and I use them all …now my best advice is that next time you guys buy a laptop make sure that it has Nvidia …they just work out of the box
    for now enjoy yourself and B nice to each other otherwise there is no point
    Finally but not least …IT IS ALL ABOUT THE OS AND NOT THE HARDWARE ,,, OSX IS THE BEST SYSTEM IN THE WORLD AND IM SURE THAT WHEN APPLES I THIS AND I THAT IS GONE WE WILL GET A MULTI PLATFORM OSX …U KNOW LIKE SOLARIS ; )

  12. darwin
    June 8th, 2011 | 4:27 am

    hola amigos he leído todos los comentarios y es verdad no hay soporte para la activación QE para la GMA X4500.

    pero existe un paquete de kexts que activa la resolución de pantalla hd y la detección de

    pantalla externa.

    aqui el link

    http://www.megaupload.com/?d=XT5OSWIM

  13. david
    June 24th, 2011 | 4:29 pm

    after installing combo update and multibeast.my mac os x does not boot again, it gets to mac logo freezes up with the CD disk icon spinning.

    i’m using HP G72 WITH INTEL CORE i3 350M AND MOTHERBOARD HAWLETT-PACKARD.
    CAN SOMEONE HELP.

  14. pepe
    July 2nd, 2011 | 10:20 pm

    Thankssssssssss

  15. pepe
    July 2nd, 2011 | 10:21 pm

    thankswss

  16. pepe
    July 2nd, 2011 | 10:21 pm

    thankss at all

  17. pepe
    July 2nd, 2011 | 10:22 pm

    thankss

  18. Pentothal
    September 28th, 2011 | 5:50 pm

    Netkas, someone says this: “……No amount of injecting of EFI strings or DSDT changes will or could help. To get native resolution you need a working framebuffer. Now all of you use VESA framebuffer which will give you only VESA resolutions (Some DELL and Sony laptops have a bit different VGA BIOS which includes their native resolution for LVDS so they already in Chameleon have native res as a video-mode). Framebuffer kext for INTELHD lacks part of code that would command output PIPEs for all cards not connected to mux (yes, in MBP with intelhd output is connected to HW mux). So it will never work if someone do not rewrite this part of kext or write a new one. And that most likely won’t happen.”

    Some other says:”If you don’t have an Intel HD chip with a secondary nVidia card, this will not work. The only way that the Intel HD kexts will work is if someone like Netkas modifies the kexts to always loopback to the Intel Card, effectively killing the nVidia string in the kext.”

    Can you tell us where the truth lies?

    Thanks in advance!

    ///looks truth

  19. Amar
    November 20th, 2011 | 1:55 pm

    One More GMA 4500 USER WITH A NOT WORKING GRAPHICS Hackintosh

  20. Steve
    January 7th, 2012 | 7:20 pm

    I´m sure there is a way please help us Genies.

    One try there so many users who are waiting for this

  21. Rico
    January 9th, 2012 | 11:07 pm

    I need help. I’ve installed the kexts, but then, the screen boots to the gray apple screen and the screen itself hangs. I hear the audio from the welcome video, but the screen itself is still at the apple gray screen. Please help ASAP!

  22. Thavid
    February 1st, 2012 | 2:51 pm

    Hi guys!

    I was able to install a Mac OS X Lion on my Intel DQ45CB. It uses the onboard GMA 4500HD which is not supported, but I was able to switch to 1600×1200!!!

    The trick was to set GraphicEnabler and Graphics Mode in BOTH org.chameleon.Boot.plist AND com.apple.Boot.plist!! And they need to be equal!! Than it was working without any patches!!!

    I wrote on the HCL 10.7.0 as well, check it out!

    Cheers

  23. Ivan from Russia
    March 17th, 2012 | 11:58 am

    Netkas I have laptop r540 ja0a with intel Pentium P6200 (Arrandale family) I can test any kext and patches. Thounsands people have Intel HD Graphics. Please help us =)

  24. TheRacerMaster
    July 21st, 2012 | 3:30 am

    @Ivan From Russia: I don’t think Intel Pentium’s use the same HD graphics as the ones in first generation Core i processors.
    @GMA 4500HD Users: I’m sorry, but stop spamming the comment thread with useless requests. There will be no QE/CI for the GMA 4500MDH. There never will be. However, the Intel HD Graphics in the Core i processors is different. Apple used them in their 2010 MacBook Pros in addition to NVIDIA graphics cards. Some editing has to be done to remove the NVIDIA references, but it’s still something that Apple has used in their machines, so it will be way easier to get working.

Leave a reply