netkas.org

MacOSX 10.6.6 released

Nothing special, just use regular update guide.

For example my Hackint0sh was updated via software update menu without any special movements, just like on mac (speedstep fixed via dsdt)

Patch for radeons 4890 to come later.

Comments

  1. Patrick
    January 6th, 2011 | 3:56 pm

    Woot thx again for the 4890 patches!

    Any chance of adding 0x9462 ID to the patches (Sapphire 4860 card, uses same RV790 core – changing the ID in RBE and reflashing works, but then no longer works in windows).

    //ok

  2. January 6th, 2011 | 4:07 pm

    Worked for me also.
    Needed to remove sleepenabler.kext – got kernel panic and then rebooted with pmVersion=0

    Cheers netkas.

  3. recoilfx
    January 6th, 2011 | 4:18 pm

    Any word on a full driver for Radeon 6XXX series?
    Thanks.

  4. SlugRav
    January 6th, 2011 | 5:05 pm

    Hello netkas!

    I have installed 10.6.6 update on my retail SL install.
    After I rebooted it, it freezes at starting the GUI.

    I have a Sapphire HD4850 with two DVI’s and a s-video.
    It ran perfectly on 10.6.5 using your qe_ci_patch for 10.6.5

    Please help 🙂

    ///add devid to ati4800controller.kext’s Info.plist

  5. SlugRav
    January 6th, 2011 | 5:17 pm

    Hello again.

    It seems that now I get a message with virtual bool IOHIDeventSystemUserClient:: initWithTask (task*, void*, UInt32): Client task not privileged to open priviliged to open IOHIDSystem for mapping memory

    It’s an AMD machine with nawcom’s legacy kernel for 10.6.5

    I’ll try adding the dev-id’s though and report

    Thank you very much netkas!

  6. tchibo
    January 6th, 2011 | 5:34 pm

    Энгри бёрдс появились под мак….)))

    А обновление только заключает в себя магаз… да и только

    ничего не слетело

  7. avian
    January 6th, 2011 | 5:45 pm

    was a frame buffer added for ati hd6xxx series cards out of interest? also any indication in the intel kexts that there is added support for intel hd2000/hd3000 sandy bridge gpus?

  8. archiboy
    January 6th, 2011 | 7:04 pm

    I’m guessing the text: “Patch for radeons 4890 to come later.” is why I’m seeing no joy 🙁

    Luckily I have a second card in my box to work with until the updated patch is available. Be warned if you have a 4890 and no backup video 10.6.6 broke my ability to use the Radeon card. I suspect others may have similar problems.

    Thanks to this site for all your hard work – I’m still not ready to give up my MacPro1,1

  9. flu
    January 6th, 2011 | 7:06 pm

    just restored to a time machine backup… can’t wait for the patch =)

  10. SlugRav
    January 6th, 2011 | 7:32 pm

    Adding the dev-id didn’t change anything.

    The only weird thing that happens, is that the HDD LED is always on.

    Hmmm…

  11. sithtoast
    January 6th, 2011 | 7:40 pm

    I added my devid (radeon 4830) to the 4800 kext and got full resolution but no qe/ci.

  12. Helixs
    January 6th, 2011 | 7:46 pm

    Ati 4650 xfx 1 gb don’t work!!!! Edit boot list add 10.6.4 and glitch image. Delete kext and restar ok but 1024 x 768 no qe

  13. Ken
    January 6th, 2011 | 9:13 pm

    Hi, can you please approve pending forum registration requests or allow guests to download forum attachments? I’m sitting on a card, but can’t download the roms I need from your forums.

  14. Majkel
    January 6th, 2011 | 9:33 pm

    I have Radeon 4850 and I always have to use QE CI Patch, adding dev-id doesn’t work (black screen with white squares). For impatient users: patch from 10.6.5 has worked for me with the new 10.6.6 🙂

  15. roger_cwb
    January 6th, 2011 | 9:48 pm

    Lost GeForce GTX 460 support, even if reinstall Nvidia Quadro 4000 drivers. 🙁

    The resolution was set to 1024×768.

  16. Wiflye81
    January 6th, 2011 | 9:57 pm

    No luck with the HD4890 (stuck on loading screen), I will have to wait for the patch.
    Great work for the previous release.

  17. roger_cwb
    January 6th, 2011 | 10:11 pm

    EDIT: SOLVED!!!

    Just reinstall with the packages directly.

    . Run Nvidia Driver
    . When window open right click NVIDA Retail Mac Driver and choose: Show Package
    . Inside Packages folder run the 3 PKG files (Display Driver.pkg, OpenGL Driver.pkg and Video Driver.pkg)

  18. Helixs
    January 6th, 2011 | 11:15 pm

    Reinstall kexts edit boot plist and nothing in hd 4650 saaad!!

  19. Bee2
    January 7th, 2011 | 12:09 am

    I’ve lost qe/ci on my radeon 4870×2.
    I’ve tried to run again the 10.6.5 patch but it didn’t work. Any suggestions?

  20. Dirk
    January 7th, 2011 | 1:55 am

    Is there a 10.6.6 sleepenabler available already?

  21. January 7th, 2011 | 7:22 am

    ATI Radeon HD4890 1GB on Gigabyte GA-EP45-UD3L board = very thankful for Netkas.org!

    Spasiba!

  22. Wiflye81
    January 7th, 2011 | 7:55 am

    @carlnunes: how you made it works ? inject device id into kext ?
    I tried to reapply exotic patch 10.6.5 from netkas but no luck.
    I haven’t a particular vendor, pure ATI.
    Thx

  23. henri
    January 7th, 2011 | 11:18 am

    Thanks !

    I have an ATI RADEON 4890 1Go Spharrie
    Id 0x9460.

    The graphic card runs in Mac OS X.6.6 without patch 🙂 !

    //it doesnt, check qe/ci 😛

  24. Frank
    January 7th, 2011 | 11:21 am

    Carlnunes: So, your 4890 is working with QE and everything? How?

  25. raziel
    January 7th, 2011 | 12:17 pm

    roger_cwb : how did u get gtx 460 to work in the first place? Is qe/ci working? Please share! Tq!

  26. January 7th, 2011 | 2:46 pm

    I don’t get it. Is the exotic patch out or not?

  27. Tze Heng
    January 7th, 2011 | 4:04 pm

    fix for qe/ci: just add your device & vendor id string into the info.plist of ATIRadeonx2000.kext and ATI4800Controller.kext

    slightly more detailed steps here:
    http://tzeheng.com/blog/2011/01/07/how-to-fix-qeci-for-4890-after-10-6-6-update/

  28. brockwitting
    January 7th, 2011 | 4:14 pm

    I would literally give $$ if there was a way for Nvidia 5xx support 🙁

  29. a Martin
    January 7th, 2011 | 4:33 pm

    @carlnunes

    So you didn’t need any patches for your 4890 card to work with 10.6.6?

  30. Tze Heng
    January 7th, 2011 | 5:12 pm

    p/s to my post above… just realized that qe/ci is still not working… I got full resolution though

  31. tchibo
    January 7th, 2011 | 6:59 pm

    Да и забыл добывить самое главное

    Resolves an issue with some Macs (that have in ATI graphics card) in which the mouse pointer movement could become erratic if an external DVI display is connected.

    У меня мышь теперь не дергается, при цифре…. глюк был еще с лео

    Решал так: втыкал переходник dvi>vga в первый порт карты, ко второму подрубал мон… когда система включалась или выходила из сна мышь дергалась….. нужно было нажать кнопочку искать мониторы и тогда все ок

  32. Tom
    January 7th, 2011 | 7:37 pm

    4670 did work under 10.6.4 (GraphicsEnabler), did the system update straight to 10.6.6:

    now my problem under 10.6.6 screen shrugs, flickers. Any help?

  33. January 7th, 2011 | 8:45 pm

    @Wiflye81, Frank, a Martin:
    I was thanking netkas.org in advance! We are dependent on netkas.org for 4890. I’m still patiently checking the RSS feed for 4890 patch everyday.

    Spasiba netkas.org!

  34. appadmin25
    January 7th, 2011 | 9:13 pm

    is any issue updating 10.6.6 on HD4870? I’m going to update the osx 10.6.4 but just want to know if any one have any issue doing on with HD4870.

    Many Thanks

  35. hausbox
    January 8th, 2011 | 3:25 am

    Have the same problem as SlugRaw with 10.6.6 update,AMD machine 10.6.5 legacy kernel by nawcom.Hard disk working without stopping for about 6-7 minutes after boot.Also,kernel_task takes up around 300MB of RAM opposed to 180 earlier..strange,can’t seem to find the reason for it.

  36. January 8th, 2011 | 4:27 am

    Step is the same as COMBO Updates???

    Still in 10.6.2….

  37. stephan
    January 8th, 2011 | 4:38 pm

    hi,

    thanks netkas for your information.

    i have removed sleepenabler.kext for upgrade to 10.6.6. i have used the 10.6.5-sleepenebler.kext after update…. result: freeze.

    i need an new sleepenebaler.kext, because the dsdt-methode makes my machine slowly (3800 vs 5800 geekbench 64-bit points …). any ideas to get a sleepenabler.kext for 10.6.6 installation?

  38. January 8th, 2011 | 6:05 pm

    i have mac 10.6.2 and tried several way to update to 10.6.5 but failed is it possible to upgrade to 10.6.6
    Dell studio 15 58
    i3 350m
    ATI 4570 512m

  39. Sleep
    January 10th, 2011 | 5:26 pm

    Yeah same issue 10.6.6 update works great but If I replace the sleep enabler the systems kernel panics on boot up.

    Anyone know anything about a 10.6.6 sleep enabler?

  40. Akin
    January 13th, 2011 | 8:59 pm

    Hey there,

    İ got a 4850 and just update my hackintosh 6.4 to 6.6 then i open osx with -x command amd update 4800.kext and support.kext.

    After i restar my osx with -v option system halt and kernel log is

    Failed to load executable kext atiframebuffer.kext

    atiframe buffer trace

    And as you know i just stuck in here.

    Any idea or comment will be great. Thanx in advance

  41. mimic
    January 15th, 2011 | 9:51 pm

    Have HD4850, previous updates (from 10.6.3 to 10.6.5) I was fixing by restoring 3 kexts: ATIFramebuffer, ATISupport and ATI4800Controller. After 10.6.6 update – can’t make GUI running (same as after previous updates without restoring kexts – black screen with white random noisy blocks of pixels). Restored 3 kexts – same result.

    Please give a hint how to solve it from “single user mode” because have no gui and no dongle (подскажите куда копать собственна)…

  42. roger_cwb
    January 16th, 2011 | 9:03 pm

    @raziel: download Quadro 4000 drivers (for Mac) from Nvidia site, if you update to 10.6.6 follow this steps:

    . Run Nvidia Driver
    . When window open, right click NVIDIA Retail Mac Driver and choose: Show Package
    . Inside Packages folder, run the 3 PKG files
    (Display Driver.pkg, OpenGL Driver.pkg and Video Driver.pkg)

    PS.: you need the last Chameleon version or ANVAL boot loader and put GraphicsEnabler=yes in your boot.plist

  43. rrusek
    January 17th, 2011 | 4:58 am

    hausbox

    Did you get your problem resolved? I have a similar issues. My hd light stays on for about 6-8 minutes then the system pretty much comes to a halt. Just get the spinning top and you need to hard reset the computer. Works fine under 10.6.5. Tried both the combo update and the software update. Running on ASUS p5w delux.

    Any help is appreciated..

  44. ultimo
    January 25th, 2011 | 10:26 am

    @brockwitting

    Pay the same $$ to get a 8xxx / even better gfx card!

  45. MacFoern
    February 18th, 2011 | 7:21 am

    GTX295 single PCB (Gainward) won’t work on 10.6.6.
    GraphicsEnabler=No, NVGTX295fix.kext, EFI-String, DVI-Out.
    Only a noisy picture, then it goes deep black.
    Worked for me since 10.6.0 -.-

  46. MacFoern
    February 18th, 2011 | 12:38 pm

    What I found out….

    NVidia Graphics Updates in 10.6.5/10.6.6 will break support for GTX295.
    Driver downgrading to 10.6.4 will start OS X but causes black and white artifacts.
    Statusbar and dock are full white, background black. The mouse cursor is visible.

  47. MacAl
    April 11th, 2011 | 11:57 pm

    Ati 4830 Working very nicely – although it shows as 4870..while its stable as a rock…cant install FCP or AVID…yet errors on install, but I think that is due to other reasons ( I know AVID fails with no audio card installed)…but otherwise A-OK…if you have a Ati 4830 & are having hasstle..put in your specs here..see if its similar to mine..maybe I can help..

    About this Mac..

    ATI Radeon HD 4870:

    Chipset Model: ATI Radeon HD 4870
    Type: GPU
    Bus: PCIe
    Slot: Slot-1
    PCIe Lane Width: x16
    VRAM (Total): 512 MB
    Vendor: ATI (0x1002)
    Device ID: 0x944c
    Revision ID: 0x0000
    ROM Revision: 113-B7710C-176
    EFI Driver Version: 01.00.318
    Displays:
    SyncMaster:
    Resolution: 1680 x 1050 @ 60 Hz
    Pixel Depth: 32-Bit Color (ARGB8888)
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Rotation: Supported
    SyncMaster:
    Resolution: 1680 x 1050 @ 60 Hz
    Pixel Depth: 32-Bit Color (ARGB8888)
    Mirror: Off
    Online: Yes
    Rotation: Supported

Leave a reply