netkas.org

GTX 570 works in Lion DP2

The Rominator just reported that GTX570 works in Lion DP2 (and most likely gtx580 too).
Image and video hosting by TinyPic

All you need is adding dev-id into Infi.plist of NVDAGF100Hal.kext and injector of your choice

Some 3d glitches, but gtx480 has some 3d glitches in Lion DP2 too.

Comments

  1. April 9th, 2011 | 4:35 pm

    is it work for gtx 580 / 590 ?

  2. jeff
    April 9th, 2011 | 5:20 pm

    @ regae -> “and most likely gtx580 too”
    WE DONT KNOW, NEXT TIME READ.

  3. Yolanda
    April 9th, 2011 | 5:54 pm

    GTX 570, 580 and 590 all use the same GF110 chip, so only add exactly yours id into the kext and all, 99.9% it will work.

  4. Breathless
    April 9th, 2011 | 6:03 pm

    Does the 560 Ti have the same GF110 chip?

  5. Yolanda
    April 9th, 2011 | 7:30 pm

    No, GTX 560 Ti it’s a GF114, but try, they all same architecture.

  6. The Rominator
    April 9th, 2011 | 10:49 pm

    Emphasis here is on “preliminary support”

    The card works for many things, but not for others. SC2 got me a black screen with the usual green cursor.

    I have been trying to get better function by creating an EFI ROM but there are unique challenges for new GF110 cards that have so far stymied me.

    Better luck using a Hack for now. Someone must have a GTX580 to try out?

  7. Jumpy
    April 10th, 2011 | 1:34 am

    Nice find! 😀

    How’s the situation with the AMD Radeon HD 69xx Series Cards, btw, anyone? 6950/6970/6990, anything of anything?

  8. Clubber_77
    April 10th, 2011 | 8:12 pm

    здорово! подожду,когда появятся первые удачные запуски GTX 580, и сразу в магазин менять свою 470.

  9. pita
    April 10th, 2011 | 9:23 pm

    thats good news, I can eventually move on to the GTX line, I was worried that I would have to be stuck with my 275GTX for another good while.

  10. rabhw
    April 11th, 2011 | 5:39 pm

    Not to derail, but I’m also eagerly awaiting any information on the 69XX series from AMD.

    Glad the high-end Nvidia cards are making good progress though 🙂

  11. tdtran1025
    April 11th, 2011 | 7:04 pm

    Can someone please publish a list of dev-ids of all cards from GF100 and up?

  12. The Rominator
    April 11th, 2011 | 10:42 pm

    tdtran1025..here is your chance to contribute !!!

    If you can’t find a current list via “Google” do what I do, look through here:

    http://www.techpowerup.com/vgabios/

    then find one of each card in Fermi family and see what the device id is.

    Should take less than 10 minutes to get it figured out, you can see device id on the “details” page

    And I would not plan on using a GTX5xx card for a daily system just yet, Lets hope DP3 will bring complete support.

  13. jherbert16
    April 13th, 2011 | 10:24 pm

    Yes, with the dev-id the 580 is indeed alive in Lion.

  14. Snill
    April 13th, 2011 | 10:34 pm

    Help please!!!
    How I can install Mac Lion on my system? I tried 2 days but no luck until now.
    I can’t make iBoot USB but I use XPS or what you call it.
    Then I can boot up with usb, but I can’t go to the next level of installation. it just stock on it or it says (pci configuration begin) and nothing happen.
    I tried all tutorial on internet 😉
    This my hardwares lists:
    1. Gigabyte GA-EP45-Extreme
    2. Gigabyte GTX580 Geforce
    3. 8 GB of Ram DDR2
    4. Intel Core Due Quad 9650
    the reason I wanted to install LION is that I’v heard I can run my GTX580 on it.
    Thanks

  15. Jumpy
    April 14th, 2011 | 3:13 am

    Use Disk Utility to create a Partition, add the Installer .DMG File to the Disk Utility Sidebar, then click on your new Partition, label it idk “Install DMG Lion” or whatever, click on the Restore Tab,

    Source: (Lion Install .DMG)
    Destination: Drag your “Install DMG Lion” Partition from the Side Bar into there.

    For pictures google “Installing Snow Leopard without CD” or something similar. Works the same with Lion.

  16. Snill
    April 14th, 2011 | 11:07 pm

    I couldn’t install Lion DP2 but I installed Lion DP (first one).
    But now I can’t boot in to it, I don’t know why. I tried many iBoots and XPCs but no luck.
    Any one has any fix for it? thanks

  17. Marucins
    April 18th, 2011 | 6:00 am

    @Netkas glitches U mean

    http://a.imagehost.org/0928/IMG_0224.jpg

    http://vimeo.com/22514878
    http://i.imagehost.org/download/0674/20100514_3

    My game that has a problem with “noise/glitches” when i run it in windowed mode – working properly. This problem occurs only in full screen mode.

    On the screen during start game or switch it off game, began to appear a strange “noise/glitches”.

    The problem is only in games. “Noise/glitches” after a while they disappear automatically.

    //no, I didnt mean that, what u haev is hdcp failure, jsut replug you display cable (or switch off/on the display) and it will disappear till next time.

  18. shukidevdas
    April 18th, 2011 | 8:17 am

    is there any way to like “extract” whatever it is thats making the 5xx nvidia work on lion and apply it to sl?

  19. shukidevdas
    April 29th, 2011 | 7:41 am

    so i finally got lion up on my p8p67 ws revolution with intel i7 2600k 16gb gskill. the problem is its really slow, i think i need a custom dsdt for my board. also i have the 580 gtx and would love to make it work but im a noob and not very sure how to open infi.plist and edit with “0x10DE 0x1080” for my 580gtx! 🙁 can someone point me in the right way to do this please?! thx in advance, really appreciate it.

  20. imusix
    May 2nd, 2011 | 1:05 pm

    Chinese:

    请问,这样是否表示GTX570已经可以在Hacintosh下工作了?是否可以表示,可以放心去购买GTX 570了呢?

    ———————————————————–

    Excuse me,Does this mean that the GTX570 has been able to work under Hacintosh? Whether can purchase GTX570?

    Thanks ~~~

  21. shukidevdas
    May 4th, 2011 | 4:10 am

    can someone make a tutorial on how to get the nvidia 580 gtx working on lion dp3? would greatly appreciate it 😀

  22. Stanly.ok
    May 13th, 2011 | 10:40 am

    2 shukidevdas you need to install Path Finder app (=

    then, in Path FInder, navigate to System > Library > Extensions > NVDAGF100Hal.kext > rightclick it > show package contents > contents > Info.plist > paste your ID under IOPCIPrimaryMatch section(you’ll see bunch of similar codes) > save file > ta-da! 😀

  23. Marucins
    May 24th, 2011 | 4:20 pm

    The glitches problem was solved. Everything of this adapter DVI to HDMI! ZOTAC adapter, included with the card.
    I had lost so much time with this f***** bug.

    ZOTAC blame! That they did this adapter.

  24. Johnny
    July 22nd, 2011 | 8:03 pm

    0x124010de&0xffc0ffff

    how would I add my info (gtx 580)10DE-1080 ??

    would that be : 0x124010de&0xffc01080

    ?
    thank you all

  25. Johnny
    July 24th, 2011 | 4:09 am

    Ok, figure it out ( 0×108010de&0xffc0ffff )
    I’m just not using any injector…
    i’ll repost soon as I get a result!!
    thank you!

Leave a reply