netkas.org

Fixed booter for Lion

It seems all you need for Lion to boot successfully on boot-132 is masking interrupts before running kernel.

It was found and fixed by cparm, but now he left the scene and allowed to release anything he made.

Here is updated pcefi and sources, no more double fault panic, you can find the fix in boot.c

Can boot only Lion, -usecache can be used to speed up booting, but works fine without it too.

Comments

  1. Andy
    May 8th, 2011 | 5:00 pm

    I have a newer version based on the latest trunk build of chameleon that you can try here http://www.mediafire.com/?b8ion36rp3e0s4z

    If you install all of your usual Extra/Extensions kests to System/Library/Extensions and then try booting with ‘UseKernelCache=Yes’ as a boot flag it should boot up a shedload faster.

  2. Crna Brada
    May 10th, 2011 | 5:29 am

    Andy,

    I’ve been using your versions for several days now and there is a significant overall improvement. But, a significant issue exists: Display Port on ATI 5870 Saphire card is not working properly.
    1. Video card is healthy and it does recognize Apple Cinema Display 27″ (ACD) but the monitor goes black after completing entire boot sequence.
    2. DVI output works perfectly well but only if nothing is connected to DP.
    3. In case of two monitors: one on DVI and the other on DP, both stay black until you phisically disconnect ACD. Then DVI monitor comes to life and if you connect ACD, Mac starts behaving as if both are functional: system preferences->displays identifies both of them properly, you can see on back-to-my-mac the images of both, etc, etc, but ACD is entirely black.
    4. In a similar setup but with Apple genuine ATI 5870 card, everything works fine as long as two monitors are connected: one ACD on MDP and other on DVI.
    5. In case ACD alone is connected to genuine Apple 5870, ACD goes black if DVI monitor is not connected. Once you connect DVI monitor, everything goes to normal.
    IMPORTANT: Both setups work flawlessly in any and every setup but under SL 10.6.7 with Kabyl’s boot file and Chameleon RC4 684. I also got Saphire 5870 and ACD working once under Lion with I believe Netkas boot file and boot0 and boot1h from Chameleon RC4 684 -system would crash on restart, freeze, etc but video was there. But I cannot repeat that “success”.

    Thanks for your hard work and let me know if I can be of any assistance.

  3. kubaf
    May 14th, 2011 | 10:54 am

    Latest update works with no problems. Start with dp2 then straight update to 11a459e via downloaded package and NOT software update!

  4. papa
    March 10th, 2012 | 7:01 am

    111

  5. Lalu
    May 1st, 2012 | 4:10 pm

    Is the hosting site down? Sends me to mirror.netkas.org which gives me a timeout and says to reload later.

  6. domini99
    October 21st, 2012 | 8:23 pm

    Hey, the download link is outdated.
    i really need to download those files to get my hackintosh installing.

    would you please upload them again?

Leave a reply