RadeonHD 4850 and Leopard, finaly!

using 10.5.7 beta ati drivers (jsut five kexts) and new natit, i got my 4850 working in 10.5.6 Leopard πŸ™‚

You need to have OSX 10.5.6 or higher

What’s working – qe/ci, resolution change

What Problems:

currently only second dvi port works for me, and only with dvi-vga adapter

also, Display is recognized as standart vga/svga display, so only 4:3 resolutions available

only usefull for VGA connections – Β with switchresx(before using it, make sure u can change resolution)Β help i added 1680×1050 mode jsut fine πŸ™‚

EDIT3(for4850): booted with dvi2vga(converter only, no monitor attached to it) in second port, and dvi connected to first port(closest to mobo), and voila,

display on first port properly recognized.

some vertical little screen jerkness sometimes

Pkg with drivers Β you will find in #radeonhd room on

and now some screenshots

Free Image Hosting at

Free Image Hosting at

Free Image Hosting at

User with 4870 reported he has almost no problems with 4870, he just cant change resolution, results in black screen

Free Image Hosting at

Btw, 10.5.7 kernel also supports Nehalem i7 fully now.

P.S. I hope no other company than Apple/AMD will pretend they wrote drivers for 4850/4870 or nehalem i7


  1. macolic
    April 23rd, 2009 | 2:26 pm

    any reference to 4350? known facts? working/not working? how to?

  2. macolic
    April 23rd, 2009 | 3:26 pm

    also netkas: can you tell us how you get the videobios info so we can make our own binary codes to add into the natit… maybe this can increase the amount of tests… esp for different 4000 series…

  3. macolic
    April 24th, 2009 | 12:29 pm

    netkas: ok rbe can extract hex, after that, do we need to alter/modify anything in the settings of voltage/fan/memory/gpu clocks? and what will be those aterations based on? thanx

  4. JohnnyO
    April 26th, 2009 | 1:44 am

    Works AWESOME.

    Netkas is simply the greatest.

    Works great with Dual HD4850 volt modded to 780Mhz.
    It’s in CrossfireX, but I don’t need to remove the bridge for 10.5.6 to see two separate cards in Leopard.
    My E8400 is running at 4.2Ghz, but Leopard on sees 3.8Ghz.

  5. Jake
    April 29th, 2009 | 4:22 pm

    Hi, i had the blue screen flash problem on the dvi ports on my gainward 512mb 4850.
    i solved it by typing in “-f -v” at boot and it changed to native resolution (1440×900) automatically and works fine.

  6. DVD
    May 4th, 2009 | 10:53 am

    Hello, I have a PC with MSI – K9A2GM V2 motherboard, Phenom II X3 720 CPU and Saphire 4850X2 2GB VGA. Installed OSx86 iPC Universal PPF5. It work pretty well, just I can’t make VGA to work. Is there any kext for 4850X2 or atleast a way to change resolution? Or 4850X2 is not supported at all and never will?
    I try download this pakeges and install, after reboot don’t booting again.
    VGA Device ID: 0Γ—9443. Can anyone help me ?

    Sorry for my broken english.

  7. Dean
    May 21st, 2009 | 8:19 am

    Is there any word on the ATI 4670 problem yet? I have an actual Mac Pro 1.1 OS X 10.5.7. If I need to go an earlier version of OS X to make this work I can do that or if it looks like there will not a solution I guess I have to go full windows 7 then.

  8. June 25th, 2009 | 1:22 pm

    thank you very much.i am very happy because this is very good news.

  9. Drumming Demon
    July 6th, 2009 | 9:24 am

    Could someone confirm that support for ATi HD4670 in Snow Leopard is scheduled? Or is it possible Apple will support it? Thanks in advance!

  10. blackwolf
    July 8th, 2009 | 11:24 pm

    Hi everyone
    I have a sapphire 4870 512mb and I tried to install using aty_init and natit but without success on sys profiler it appears as radeon 4870 but without qe & ci and no resolution change too and memory recognized is wrong..sincerely i have not understood how i have to do for install kext,
    What and how many kext i have to download and install for my 4870?i have ideneb 10.5.6

  11. Amacx86
    July 11th, 2009 | 3:58 pm


    My system: AMD Phenom 9950 @ 2.6, MSI K9A2 mainboard, ATI Radeon 4850 (also MSI).

    I was running iDeneb 10.5.6 @ 1024×768…downloaded your drivers, installed, them and now have 1280×1024 on reboot without even touching the Linux shell.

    The only little catch is every so often the screen will look like it just shakes a hair, down then back up.

    But I’m really glad I have the res. Thanks a lot for your work in this area!

    ////u dlaoded some old natit prolly, use latest one and no screen shakes then.

  12. Amacx86
    July 13th, 2009 | 6:18 pm

    Yeah, I think you’re right. I downloaded this one:

    and it’s fixed the screen shake.

  13. Fabulous
    August 2nd, 2009 | 12:12 am

    I really don’t get my hd 4850 working in 10.5.7. I’ve already tried everything, any natit.pkg or driver packages. I’ve tried several combinations of kexts, for example natit and ATY_Motmot i found anywhere. I followed several guides but nothing worked for me. Can you help? Maybe I’m out of date but i really searched.

    ////am I looking like telepatic ?
    ///if u use vga display, then there is almost no hope.

  14. Fabulous
    August 2nd, 2009 | 12:17 pm

    i use an 22″ widescreen monitor with dvi2vga.

  15. appwei
    August 6th, 2009 | 3:56 pm

    Hi everyone:
    My Radeon HD 4850 is (HDMI/DVI/VGA),I tried,but it doesn’t it possible Apple will support it? Can anyone help?Thanks in advance!
    (iATKOS_v7 10.5.7 system)

  16. Cuong273
    August 12th, 2009 | 9:23 am

    i have resolution problem with my HIS4850, my monitor have 1440×900 res but in the System Preference it doesn’i show, there are many of resolution but online for 4:3 CRT monitor
    I use iDeneb 10.5.7 and connect with DVI2VGA conveter in second DVI port( far motherboard)
    please help me:(

    ////it was already described on this blog, go search.

  17. Aaron
    September 12th, 2009 | 3:13 am

    Omg can someone please help me.
    I’v looked everywhere and can’t find the drivers for 4870.
    Your all talking about installing the drivers but where do you get them from?

    Can someone please post a link

  18. September 20th, 2009 | 6:49 pm

    Downloaded from here and installed but nothing happened. Nothing shows in display settings other than 1400×1050 which I already had. Am I missing something here? Was I supposed to do something else with the .pkg file?

  19. Lee Ferry
    September 30th, 2009 | 7:21 pm

    My VGA DA4870,i have following the instruction above…..but i’m still have a problem…because when finish instal a driver and restart,my display can’t show (blank screen) and have a notification family display matching fails.Can help me to tell what a problem….please ????

  20. diaz2010
    October 22nd, 2009 | 5:23 am

    Is there anyway to get a kext for the ATI Mobility Radeon HD 4670 since the new iMacs have support for the 4670? I know you said you would ignore all new posts about this, but please answer.

    ///soon, not sure about mobility tho, apple may not support lvds this time too

  21. henrique
    November 29th, 2009 | 10:58 pm

    help me with saphire hd4850 512… tried this methods but only blue screens and kp….
    i`ve tried with the drivers from ideneb 10.5.7 ( whith hd48xx drivers and resolutionFIX) and at the first time it works fine…. qe/ci and resolution change, but when i shutdown and star again it stops and looks like out of sync.
    PS: this card have this ports (left to right) vga – hdmi – dvi

    sorry about my english i`m from brazil… i hope u understand!

  22. January 26th, 2010 | 2:05 pm

    @PcMacZone thx for the link… im gonna try it out.

    I just set aside my 4670 because it was too difficult to patch up… I hope this 4850 is easier!

    if n e one wants to buy a 1GB 4670 look me up!

  23. March 3rd, 2010 | 4:18 pm

    […] the end of March. And in a final piece of related news, the latest Mac OS X 10.5.7 developer seeds has been revealed to already “fully” support the Nehalem […]

  24. AnathemaMoon
    April 11th, 2010 | 3:49 am

    I was having a gray/funky screen when installing all the texts, so I decided to install them one by one. I have a Sapphire ATI Radeon 4830 HD. I’m not entirely sure if the order matters, but here’s the order I did them in anyways.

    1) Natit
    2) ATY_Init
    3) ATINDRV

    And that’s it. Hope this helps!

  25. ice
    July 6th, 2010 | 12:28 pm

    “10.5.7 beta ati drivers ”

    where can I download the drivers and how to install?
    I googled but find nothing… can anybody post a link?

    //you dont need them, just install 10.5.8

  26. Fran
    August 13th, 2010 | 1:18 pm

    Were is the download link, have never been on this site before. πŸ™‚

  27. August 31st, 2010 | 9:39 pm

    wow thnx! that was the golden tip πŸ˜€

  28. Thijs
    September 28th, 2010 | 1:20 am

    Need support for ATI mobility 4670… Anyone have had this card work succesfully? Dell XPS 16 πŸ™‚

  29. December 16th, 2010 | 10:29 pm

Leave a reply