netkas.org

Got 6970 working!

It’s only for Lion.

Small how-to
1) get 10.7.2 11C48 beta (from imzdl.com for example)
2) Install all ati kexts from update with pacifist (or install whole update)
3) download this file – removed and copy it to this folder – /System/Library/Extensions/ATIRadeonX3000GLDriver.bundle/Contents/MacOS/
4) install aty_init if you dont want dvd payer/steam/etc to crash (not for macpro). – removed

there is still few small glitches (MSAA crashes driver, opencl doesnt work) here and there.

if it stops at gray screen, reset computer, happens sometimes.

Comments

  1. Upsworld
    December 2nd, 2011 | 12:25 am

    Hi and first of all thx to netkas for all this

    I got my xfx 6950 2gig running but not completely. If i set on all graphics features in 3D Games at some quality setting it freezes. Also Chess doesnt work. How can i see if opencl is working? Is there yet any opportunity to make it fully working with all features? If not: is it coming with 10.7.3?

    Thx for your answer and again thx to godlike netkas

    ///OpenGL isn’t working, and disable AA in your games

  2. December 2nd, 2011 | 11:59 pm

    […] […]

  3. December 6th, 2011 | 1:18 pm

    Yeah, I don’t need anything special when it comes to 3d performance, and just some config file to compare my setup to would be really nice, since I already have my system up and running with the open source driver I want to stay away from the problems that could bring. Besides I never had a problem with Ubuntu 11.10 when I tried that and played a couple of game off of it, but I was rather disappointed at how unstable and unfinished it felt, and I wanted a lot more control of my system from the ground up, so I switched to Arch Linux.

  4. Stefan1968
    January 22nd, 2012 | 6:48 am

    Works perfectly for me. HD 6xxx chipset has been successfully recognized. Using a Powercolor 6950 PCS++ at 2GB. Next: will benchmark the performance!!!!

    Thanks a lot guys for all the help in this threat.

  5. Motawa
    February 3rd, 2012 | 3:45 pm

    I’m getting a gray screen with the cursor at every boot when installing iAtkos L1 with every graphic option. Choosing chimera + graphicsenabler=no and ATY_init gets rid of the “unsupported card” message, but i still get a gray screen with a working cursor. What to do? <—– please help got the same problem

  6. February 27th, 2012 | 5:45 pm

    […] […]

  7. Bukreev
    March 2nd, 2012 | 5:32 pm

    Finaly!!! My ATI Radeon HD 6950 Sapphire Flex edition 2048Mb and Lion 10.7.3 is WORKING!!!!! Three screens connected and all is working! Framebuffer – Gibba

    Thanks a lot, Netkas!!!!

  8. posteem
    March 4th, 2012 | 2:43 pm

    bukreeev, your is the first i have seen working in 10.7.3, would love to know your other driver combinations….

  9. Bukreev
    March 11th, 2012 | 5:46 pm

    Motherboard: ASUS P5E
    CPU: Intel Core 2 Duo 2,66Ghz
    RAM: 6Gb
    Video: ATI Radeon HD 6950 Sapphire Flex 2Gb

  10. March 19th, 2012 | 4:24 pm

    Bukreev, what method you have used? Step by step please.
    (if this will not be helpful, I’ll sell my card) 🙁
    (Gigabyte Radeon HD6950 OC 1Gb)
    Thanks!

  11. cristianfloyd
    March 27th, 2012 | 4:14 am

    Hi, 6970package cause “still waiting for root device”.
    Sorry my bad english.
    I installed two files from netkas and working very fine for me, but some apps crash and no gl acceleration. I have ati 6950 1gb. Later I installed andy package and goes wrong, I believe that have to delete previus files, but for some reason Lion dont boot any more.
    I read previus post with this error, and andys sais that package only write two files or something. I deleted ATY_init but system dont boot anymore.

    Please Andys tell us what are doing that package to track error.

    thx.

  12. thembdude
    April 3rd, 2012 | 1:01 am

    Zeus 2.8 wont recognize 320m in white Macbook. Help?

  13. pumpgun22
    May 10th, 2012 | 6:17 pm

    where can i get this ATIRadeonX3000GLDriver.bundle ?

  14. July 22nd, 2012 | 6:16 pm

    […] […]

  15. O.B
    January 31st, 2015 | 1:26 pm

    Is this package going to work in Yosemite?

Leave a reply