netkas.org

iCloud on Hacks

For iCloud working on Hacks you need to find updated booter.

afterwards it works fine.

if you have link to the info about what was changed, post it into comments.

Comments

  1. rene204
    October 15th, 2011 | 7:09 am
  2. October 15th, 2011 | 10:18 am

    What is wrong with iCloud on hacks and how does it depends on booter? Worked fine for me since beta.

  3. PC Chopath
    October 15th, 2011 | 10:25 am

    Yes, same as caine. no problem, since beta (developer) version, master! 🙂
    http://cl.ly/Az83

  4. Jan
    October 15th, 2011 | 11:18 am

    I think at least Find My Hack doesn’t work (not that I need it though), everything else seems to be fine.

  5. Bill
    October 15th, 2011 | 11:30 am

    Well, it required the FaceTime fix which was remove somehow from chameleon and chimera. By updating to the newest chameleon or chimera it`s then activated by default.
    Also U might wanna work on ur sn code as well, as I have encounter a message yesterday saying that my id cannot create any more iCloud ids, use a chameleon tool to generate a new one into smbios and i was sweet.XD

  6. October 15th, 2011 | 11:41 am

    To make Find My Mac work only recovery hd and wifi network needed

  7. hackmack
    October 15th, 2011 | 12:21 pm

    Actually, alll I had to do to get it to work on my system (iBoot+Multibeast) was to change the serial # of my hackintosh. Apparently many of the installers use a generic serial#, and since they all use the same one, Apple banned it.

  8. Darwin
    October 15th, 2011 | 1:57 pm

    Comment 3 by Yann Quéniart, Oct 7, 2011

    “The part of the introduce in build 1493 for FaceTime fix solve the
    problem :
    fake_efi.c
    ….
    static const char const BOOT_UUID_PROP[] = “boot-uuid”;
    ….
    //Facetime fix start
    Node *ChoosenNode;
    if (gBootVolume->fs_getuuid &&
    gBootVolume->fs_getuuid (gBootVolume, uuidStr) == 0)
    {

    ChoosenNode = DT__FindNode(“/chosen”, false);
    DT__AddProperty(ChoosenNode, BOOT_UUID_PROP, 64, uuidStr);
    }
    //Facetime fix end

    This code is a problem for raid users so the code have been deleted
    in build 1497.

    I don’t know if you can activate the function permanently without
    cause problem for RAID users.

    If you can’t perhaps an activation of the FaceTime fix in
    org.chameleon.boot.plist can solve this issue.”

    Reference: http://forge.voodooprojects.org/p/chameleon/issues/188/

  9. October 15th, 2011 | 3:11 pm

    So far 755 works best for me. FaceTime + iCloud + RAID.

  10. SG
    October 15th, 2011 | 3:25 pm

    depending on how old or new your boot loader is, it might have worked in the betas. you need a boot loader that has the facetime fix, however the fix does not work with RAID bootable device so it was taken out of officlal chameleon branch. only some builds of chameleon had the facetime fix as well as other branches (such as chimera).

  11. Stanly.ok
    October 16th, 2011 | 1:49 am

    at first iCloud, AppStore and Facetime didn’t work

    after installing Chameleon r1627 everything works fine!

    also no more ATY_Init needed for GTX580, just “GrahpicsEnabler=yes”

    on a side note: graphic performance improved a lot, everything looks snappier! Cinebench R11.5 score went from 11fps to 42fps! Windows 7 is still better at 75fps, but I think with the next update the difference will disappear … I wonder if Apple puts some nVidia’s in next generation Mac Pro’s 😀

  12. Shiro
    October 16th, 2011 | 11:02 am

    Here more Info about that Problem….

    http://forge.voodooprojects.org/p/chameleon/issues/188/

  13. SG
    October 16th, 2011 | 2:02 pm

    if you were getting 11fps previously, something was seriously wrong with your video drivers setup or your cpu being down-clocked from PM features. 10.7.2 is almost the same as 10.7.1 for performance, there are no major driver changes.

  14. Stanly.ok
    October 17th, 2011 | 12:00 pm

    2 SG – drivers for GPU improved a lot:

    http://s017.radikal.ru/i411/1110/93/520814ebf890.jpg

  15. SG
    October 17th, 2011 | 2:25 pm

    you just had something badly misconfigured in 10.7.1 to get that bad FPS.

  16. SG
    October 17th, 2011 | 2:28 pm
  17. October 20th, 2011 | 6:03 pm

    iCloud fix now, following 3rr0rists guide with Champlist.app http://3rr0rists.net/guides/how-to-fix-icloud-on-hackintosh-lion-10-7-2.html

  18. JrCs
    October 25th, 2011 | 11:54 am

    I have fix the facetime & iCloud problem in r1649 of chameleon.

Leave a reply