netkas.org forum
May 26, 2022, 02:00:33 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Information for registering users http://forum.netkas.org/index.php/topic,2246.0.html
 
   Home   Help Search Login Register  
Pages: [1] 2 3 ... 10
 1 
 on: December 18, 2021, 01:56:28 PM 
Started by netkas - Last post by toke lahti

### AMD7000Controller.kext

* pci device: 683d - Cape Verde XT [Radeon HD 7770/8760 / R7 250X]

I have a 4,1>5,1 and asus r7 250X (“R7250X-1GD5-DIS”)
I'd like to run Mojave (10.14) with it.

Is it possible with this driver?

 2 
 on: December 10, 2021, 01:11:40 PM 
Started by Fl0r!an - Last post by toke lahti
Here is my ROM file for the XFX Radeon HD 5770 HD-577X-ZMF3 Version A.4, it is a single slot, dual DVI + MiniDP card. As Fl0r!an notes above, this isn't a reference design, so only use this rom if you have the exact make/model.

The DVI ports are working well, with boot screens from the right-hand DVI connector.

Other boot screen options:
DVI-to-VGA on the right-hand connector (always worked - even before Fl0r!an's excellent work)
MDP-to-VGA (I'm not sure if this worked before, but it definitely does now)




I have HD-577X-ZMF3 Version A.7
(7!)
Do you guys think it would work with that rom?
I'm still unfamiliar with building own rom...

EDIT: Does not work perfectly: only one port at a time, which is chosen at the time of boot.

ANYBODY could give me help for using r7 250 with 4,1>5,1 and Mojave?

 3 
 on: December 10, 2021, 11:45:19 AM 
Started by netkas - Last post by jmanx360
Anyone willing to share a Radeon HD 7770 ROM? Someone mentioned blacksheep had a working ROM long ago. Tried messaging and no response. Script never worked for me on my XFX card. It's just sitting around while I'm stuck with a GT630 in my MP3,1. I'd like to have a better Metal-compatible card without having to pay the insane prices on ebay for a card.

 4 
 on: November 28, 2021, 11:10:28 PM 
Started by toke lahti - Last post by Bunga-Bunga
Look here: http://campahunta.free.fr/Downloads/ROMs/ati_oem_EFIx1900xt_140_pcie_64k.rom.zip

 5 
 on: November 24, 2021, 02:56:17 PM 
Started by toke lahti - Last post by toke lahti
Could somebody repost this:
X1900MAC.ROM from

Pretty please?

http://forum.netkas.org/index.php/topic,2187.msg38910.html#msg38910

 6 
 on: November 23, 2021, 11:50:40 AM 
Started by netkas - Last post by wername
the bios file with the mac rom conversion is attached.
Maybe someon can fix the hdmi problem (with PC bios all works fine) :-(
thanks

 7 
 on: November 22, 2021, 09:35:23 AM 
Started by netkas - Last post by wername
Hi everybody.
I have a problem with a Powercolor 7950 PCS+ 3GB (there's this written on the card lf r19f version 1.0)
The card was included with my mac pro 5.1
Already flashed to Mac.
But the pre-owner broke the bios switch and took the model code sticker off the card :-(
The dvi port works but the hdmi port shows no screen.
Has anybody got the same card and can dump his Mac rom here?
I can only flash 1 bios of the 2 because the switch is broken :-(

Thanks

 8 
 on: August 31, 2021, 07:33:09 PM 
Started by overshoot - Last post by goodfidelity
Hi guys!

I have Mac Pro 5.1 and trying to run a GTX 780 with the rom file that is listed on the mac elite wiki website.

Running bootcamp the card boots and runs in windows.

However trying to boot into OSX High Sierra the card will freeze after about 2/3s of the boot bar.

And if i flash the original PC ROM back onto it, it will not start in OSX either.

I was under impression it should run just as fine as GTX680, and i have tried MANY of those cards with no problem.

Is there something obvious that i am missing? Do i need to install the web-drivers or not?

Thanks for any input!

 9 
 on: August 16, 2021, 11:16:37 AM 
Started by netkas - Last post by bbdjam
hi everyone,
i succeeded with your help the flash some time ago but today i would like to come back with the original rom
the problem my hard drive lost everything HS,
can you please share me the original rom of the gigabyte r9 280x oc rev card 2 to return to the factory state for windows
thank you very much

 10 
 on: July 14, 2021, 03:55:49 PM 
Started by netkas - Last post by grammataki
Successfully flashed an ASUS 7950 DirectCU II TOP
A bit late to the party, but hey we all have our things Smiley

Thank you Netkas and Rominator, and others contributing to thread with useful tidbits.

=> https://www.techpowerup.com/gpu-specs/asus-hd-7950-directcu-ii-top.b441

Card was originally working okay in Mac OS El Capitan 10.11.6 and Windows 10 Pro, with DVI, HDMI and two display ports, but wanted boot screen Smiley  Instructions straightforward, and I don't understand all the mistakes people keep repeatedly posting about - read up on terminal usage beforehand.  Read your 47 pages and troubleshoot.  Take your own ROM, and put into the script.

If it helps other, my script output was as follows:

$ cd into the unzipped bundle folder
$ ./makerom.sh --efifile=7950mac.efi --romfile=efiromheader.rom --originalrom=ASUS7950.rom --devid=679a
running on 7950mac.efi, efiromheader.rom with devid 679a
Patching files 7950mac.efi, efiromheader.rom for device-id 0x679a
Successfully patched efi file
Successfully patched efi rom file

Orig Size = 125440
Comp Size = 47591
47591+0 records in
47591+0 records out
47591 bytes transferred in 0.085020 secs (559764 bytes/sec)
EFI part is ready at 679a.efipart.rom
orig size - 65536
65536+0 records in
65536+0 records out
65536 bytes transferred in 0.119385 secs (548947 bytes/sec)
Before:
OpRom (size=65536, indicator_offset=0x225, indicator=0x80, checksum=0x0)
OpRom (size=48128, indicator_offset=0x31, indicator=0x80, checksum=0x0)
RawData (size=17408)

After:
OpRom (size=65536, indicator_offset=0x225, indicator=0x0, checksum=0x80)
OpRom (size=48128, indicator_offset=0x31, indicator=0x80, checksum=0x47)
RawData (size=17408)
the rom is ready at ASUS7950.rom.efi.rom


I have attached the ROM I flashed for reference.
Sequence was:
1.   Took note of switch position on card, it was on position 2 by default.  Put card into MacPro and booted into Windows10.  Saved this ROM for reference and shutdown and put with in   
       position 1 to work from.  booted into Windows10.
2.   Downloaded "amdvbflash_win_3.20.zip", "ati_winflash_2.6.7" and "GPU-Z.2.40.0.exe".
3.   Opened GPU-Z and took note of card ID 679a (simple step some people skipped here).
       This also verified that the card did not have UEFI as the UEFI box was not checked.
4.   Opened amdvbflash, installed driver, and saved the card ROM, placing it on a USB as ASUS7950.rom.
5.   Rebooted into MacOS (took a few tries here as Bootcamp installed in unorthodox fashion but got it eventually)
6.   Downloaded the "bundle.tar.bz2" from OP, and unzipped
7.   Placed original extracted ROM from USB to the above unzipped folder
8.   Opened Terminal, and CD'ed into the folder (dragged into Terminal) and pressed return
9.   typed './makerom.sh --efifile=7950mac.efi --romfile=efiromheader.rom --originalrom=ASUS7950.rom --devid=679a' and pressed return
10. ROM to flash appeared in folder, and put onto USB drive
11. Rebooted into Windows 10
12. From USB, placed ASUS7950.rom.efi.rom onto desktop
13. Opened up amdvbflash_win_3.20, and loaded the ASUS7950.rom.efi.rom and flashed
14. Tested by opening up GPU-Z. and checking that UEFI box was checked. Confirmed.
15. Removed installed driver for amdvbflash_win_3.20 - some security issue
16. Reboot into Mac, and voila BOOTSCREEN! Checked in System profiler and card name explicitly.  Tested card with full insane detailed resolution win XPLANE 9 and 10. Amazing

Thank you again!

P.S. Had a 6Pin Mini PCIe to 6Pin GPU power cable but had to make another one from cables and connectors I had.  A good reference table and pic attached Smiley



Pages: [1] 2 3 ... 10
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!